WordPress.org

Make WordPress Core

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#4272 closed defect (bug) (invalid)

Widgets Not Dragable

Reported by: JDTrower Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2
Component: Administration Keywords:
Focuses: Cc:

Description

While testing the installation of Wordpress 2.2 on a local XAMPP installation, the widgets area worked fine in Firefox 2.0 allowing for clicking and dragging widgets onto the sidebar. However, once I installed the latest version on the actual server (hosting is on 1and1.com) the widgets area didn't work. I was unable to click and drag widgets onto the sidebar in Firefox 2. I also tested in the latest version of Opera and IE7. The settings and plugins installed are exactly identical between the two blogs with the only exception being the version of PHP. On the local XAMPP install it is PHP 5.2.1 whereas on the 1and1 server it is PHP 4.4.4.

Change History (35)

#1 @zamoose
14 years ago

This sounds very similar to the behavior shown in #4264. I suggest the two tickets be merged, although the description here seems to indicate the issue is more wide-ranging than simply IE7.

#2 @JDTrower
14 years ago

My understanding of #4264 (as well as my experience with a test blog that is running WP 2.2 successfully) that widgets in IE7 are dragable but the appearance of the widgets.php is messed up. Furthermore, in IE7 the available widgets area can only have two rows. If you have available widgets that in Firefox or other browsers take up three rows, you only see the top two rows. However, the problem that is occurring that is reported in this ticket (#4272), is that the widgets are not even dragable. They are listed as being available, you can have more than two rows of available widgets, but you can't drag them onto the sidebar to customize your sidebar.

#3 @JDTrower
14 years ago

There has been a thread started in the Wordpress forum by another person having this same issue. http://wordpress.org/support/topic/118216

I ran the error console and firebug in Firefox 2.0.3 and they show the same three errors.

On line 282 Event.observe is not a function
Event.observe(window, 'resize', resetPaletteHeight);

On line 375 Sortable is not defined
Sortable.create("palette", {

On line 192 $ is not defined
cols.map(function(o) {var c = $(o).childNodes.length; if ( c > max ) max = c;} );

I only copied the code from the line mentioned.

#4 @JDTrower
14 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I had downloaded WP 2.2 within minutes after it being made available at http://www.wordpress.org. Apparently the zip file did not contain all of the necessary files that were needed (particularly a lot of the js files in the wp-includes/js folder. I was reading a rather old thread on the forums and ran across a thread that was talking about problems with the widgets plugin and it mentioned a missing js file. That caused me to go investigating in the unzipped files of WP 2.2 and discovered that there had to be files missing. I re-downloaded the WP 2.2 zip file and unzipped it. I went looking at the files in this new download, and there were quite a few files listed in this new download that were missing from the original download. Once I uploaded all the files from this new download onto the local server, the testing blogs that were having problems were now working. When I uploaded them to the 1and1.com server, the blog there was working. I am now able to drag and drop widgets and move them around. I don't know if it was just a bad download the night that WP 2.2 "Getz" was released, or if an updated zip file has been posted that contained all the files, and that I had downloaded an incomplete file. Either way, I have resolved the issue at least on my end. I am going to go ahead and list this ticket as resolved.

#5 @foolswisdom
14 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

#6 @foolswisdom
14 years ago

  • Milestone 2.2.1 deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

#7 @mattwiebe
14 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I've re-opened the trac ticket, because I'm still getting the same error, using both FF 2.0.0.3 and IE7. I've done the following:

  • checked my scriptaculous folder and verified that all files were intact (they were)
  • re-uploaded the entire wp2.2 release
  • checked to make sure my chmod setting were allowing reading (they are)

This is the case both on my blog and on my local xampp installation.

#8 @rob1n
14 years ago

Cleared your cache?

#9 @rob1n
14 years ago

  • Milestone set to 2.4

#10 @mattwiebe
14 years ago

I've cleared my cache, yes. I've also done multiple hard refreshes to no avail. Same error every time.

My remote host is running PHP 4.4.6 and MySQL 4.1.21 if that's of any help.

#11 @mattwiebe
14 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

I have now sorted this out. I didn't think that I had any plugins affecting my admin panel, but I finally found the culprit: Knanh's Instant Notepad. Disabling it sorted out the problem. I have let the plugin author know about the problem.

#12 @rob1n
14 years ago

  • Milestone 2.4 deleted

#13 @rob1n
14 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

#14 @rob1n
14 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

#15 @axelsegebrecht
14 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Sorry guys, not working for me either. Checked files, other plugs, etc. != joy

GET
/wp-content/plugins/silaspartners/flickr/admin-options-load.php?view=albums&rndval=1179868634089
(4196ms)tw-sack.js (line 186)

GET
/wp-content/plugins/silaspartners/flickr/admin-options-load.php?view=groups&rndval=1179868634119
(1553ms)tw-sack.js (line 186)

Prototype is not defined
[Break on this error] linear:Prototype.K,
effects.js (line 147)

Class is not defined
[Break on this error] var Draggable = Class.create();
dragdrop.js (line 224)

$ is not defined
resetDroppableHeights("sidebar-1")
widgets.php (line 161)

resetDroppableHeights()widgets.php (line 161)

updateAll()widgets.php (line 227)

wpOnload()widgets.php (line 10)

[Break on this error]
cols.map(function(o) {var c = $(o).childNodes.length; if ( c > max ) max = c;}...
widgets.php (line 161)

Sortable has no properties
[Break on this error] Sortable.create("palette",
widgets.php (line 313)

Event.observe is not a function
[Break on this error] Event.observe(window, 'resize', resetPaletteHeight);
widgets.php (line 249)

This is on Windows XP, FF 2.0.0.3 with FireBug.

Thanks in advance :-)

PS: IMHO for usability reasons this should work even without JavaScript being activated!

#16 follow-up: @rob1n
14 years ago

Dragging widgets should work even without JS being activated? It's a JS application, and it would be a waste of time to code it again, not using JS.

#17 in reply to: ↑ 16 @axelsegebrecht
14 years ago

Replying to rob1n:

Dragging widgets should work even without JS being activated? It's a JS application, and it would be a waste of time to code it again, not using JS.

rob1n, I know it is but some "important" things should have a fall-back if something goes sour (i.e. JS error), so you can at least still use it.

I'm having similar discussions with my colleagues at work (dev' weblications), and it's a balancing act but we do our best to make sure users are still able to use the app even when it throws errors at them :-)

#18 @rob1n
14 years ago

  • Milestone set to 2.4

#19 follow-up: @Otto42
14 years ago

Correct me if I'm incorrect, but I think that there is no possible way to make things "draggable" in the browser without javascript.

Creating a non-JS method of rearranging widgets strikes me as a massive waste of time. You're talking about a fraction of a fraction of a percentage of the users here. I would mark that as a wontfix and add "modern browser that doesn't suck" to the requirements... and get on with life.

#20 in reply to: ↑ 19 ; follow-up: @Nazgul
14 years ago

Replying to Otto42:

Creating a non-JS method of rearranging widgets strikes me as a massive waste of time. You're talking about a fraction of a fraction of a percentage of the users here. I would mark that as a wontfix and add "modern browser that doesn't suck" to the requirements... and get on with life.

I disagree. Just look at WCAG. According to checkpoint 6.3 of the WCAG things should function without javascript or an alternative method of doing what you're intending to do should be provided.

Being WCAG compliant is mandatory for a lot of government agencies. In theory they aren't allowed to use Wordpress as is.

Seeing that I'm the only one that uses my admin section I don't have a use for it personally, but I can see a need for it.

#21 @rob1n
14 years ago

  • Milestone 2.4 deleted
  • Resolution set to wontfix
  • Status changed from reopened to closed

So if you're really, really die-hard about WCAG, just hand-code your sidebar. I see no possible way, minus TONS of work and redundancy. I suppose it's technically possible, but I don't see enough reward for all the effort that would have to be spent.

Widgets are *meant* to be "superfluous." If they're going to function, they need JavaScript.

If you're willing to code up a decent, usable version of widgets that works without JavaScript, then attach it to this ticket and reopen it. For now, this is wontfix.

#22 in reply to: ↑ 20 @Otto42
14 years ago

Replying to Nazgul:

Being WCAG compliant is mandatory for a lot of government agencies.

Remind me to never take a job for the government.

#23 @axelsegebrecht
14 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Folks, I'm talking about two things here:

1) Please fix the JS errors so the dragging works and I can use the function! Alternatively, call me a stupid noob and let me know what I'm doing wrong :-)

2) Think about whether it might be a good to add checkboxes and a save button to each box in case JS doesn't work (so at least you can use the boxes).

Sorry if I haven't made myself clearer.

#24 @Otto42
14 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

Re: #1
Your errors most likely come from missing or misplaced javascript files, ad blockers, script blockers, plugins, or something else along those lines that's interfering with the javascript. How do I know this? Because it works fine for me, without giving me those errors. You even said it works for you when running locally. Doesn't this suggest that the problem is not Wordpress but something on your server to you? It should.

I suggest you duplicate the problem with a fresh install, no plugins, and Firefox running in Safe Mode to disable all extensions and such. Then, and only then, will we think it's a problem with the javascript itself. This does not appear to be such a problem.

If you can duplicate the problem, reopen this ticket again.

#25 @axelsegebrecht
14 years ago

Sorry Otto42, I've done a clean install in a new db and tried in IE and FF. Both give JS errors and the "array" text shows up in most empty fields. My IE JS error is the same as the one in http://trac.wordpress.org/ticket/4325.

I used the latest.tar.gz and edited everything on the box (using mcedit). I really am stumped as to why this happens but there's obviously something wrong here.

There is another post in the support forum regarding the "array" problem too. Not sure whether there's a ticket for it yet.

I will leave this closed since I'm the only one with the problem. However I shall revert back to 2.1.3 since everything worked just fine.

PS: Checking my apache error_log shows the following error:

PHP Fatal error: Unsupported operand types in /wp-admin/users.php on line 55 when I try accessing users.php from the admin. The "Authors & Users" page is just blank after the top nav bar.

#26 follow-up: @treehousetim
14 years ago

  • Priority changed from high to highest omg bbq
  • Resolution worksforme deleted
  • Severity changed from major to blocker
  • Status changed from closed to reopened

I'm getting this error on:
php version 4.3.11
fresh upload of freshly downloaded wordpress files with default theme with no plugins installed
wp 2.2 (downloaded from the main public site)

in Firefox 2.0.0.4, using firebug, I see the following errors:

Prototype is not defined: effects.js line 147
class is not defined: dragdrop line 224
$ is not defined widgets.php line 115
Sortable has no properties: widgets.php line 268
Event.observe is not a function: widgets.php line 203

I can't figure out what's going on with this.
This blog was an older version that was upgraded to 2.2
I have 2.2 running on a different server and it works fine there.

#27 @treehousetim
14 years ago

Another thing that should be noted is that the main dashboard page doesn't load properly either - The blog and the news neither one shows up.

#28 in reply to: ↑ 26 @foolswisdom
14 years ago

  • Priority changed from highest omg bbq to normal
  • Severity changed from blocker to normal

Replying to treehousetim:

I can't figure out what's going on with this.
This blog was an older version that was upgraded to 2.2
I have 2.2 running on a different server and it works fine there.

What is different between the servers?

#29 @treehousetim
14 years ago

The biggest difference I can see is the versions of php. On the server where it's working: php version 5.1.6

where it's not working: 4.3.11

But, the other difference is that the one that is working on 5.1.6 was also a new install of the database, where on 4.3.11 it's an upgrade of an existing database.

I'm wiping the database now and will let you know if a new install of WordPress on 4.3.11 makes any difference.

Thanks,

  • Tim

#30 @treehousetim
14 years ago

I removed the tables completely from the database and re-installed 2.2 without success.

Same problems, same javascript errors reported in firebug on the widgets screen.

I'm going to install 2.1.3 and see what happens.

#31 @treehousetim
14 years ago

Version 2.1.3 works on the dashboard, and when I install the widgets plugin that works also.

#32 @jamesw
14 years ago

I have exactly the same problem, I administer two blogs on the same server, one running 2.1.3 and the widgets plugin, and one running 2.2.

The 2.1.3 blog has no problem with widgets at all, but with the identical browser setup, widgets cannot be dragged in 2.2.

Is there a script include setting somewhere that's failing on some blogs (mine's an IIS type server).

#33 @Nazgul
14 years ago

  • Milestone set to 2.4 (future)

#34 @ryan
14 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Widgets admin has been rewritten. Closing as no longer relevant.

#35 @Nazgul
14 years ago

  • Milestone 2.5 deleted
Note: See TracTickets for help on using tickets.