WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#42767 closed defect (bug) (duplicate)

'update_languages' capability is not promped to admins

Reported by: wdfee Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: General Keywords:
Focuses: administration Cc:
PR Number:

Description

since 4.9 my admin user is not able to update language files anymore, no information about available language updates is shown. (But is shown in the number of available updates in admin bar and menu.)

When I change in /wp-admin/update-core.php line 630 to

if ( current_user_can( 'update_languages' ) || current_user_can( 'manage_options' ) ) {

and line 746 to

if ( ! current_user_can( 'update_languages' ) && ! current_user_can( 'manage_options' ) ) {

it works again.
So it seems somewhere the capability failed to be added to the admin.

Change History (3)

#1 @Presskopp
2 years ago

@flixos90 Can you have a look?

#3 @dd32
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Marking this as a duplicate of #42697 - you should have the update_languages cap, but it sounds like the calculation of the capability isn't correct, as per #42697

Note: See TracTickets for help on using tickets.