WordPress.org

Make WordPress Core

Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#42857 closed defect (bug) (invalid)

Warning for insecure browser is throwing PHP Warning when Site Language is different than English

Reported by: dimitris.m Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.1
Component: General Keywords:
Focuses: Cc:

Description

Steps to reproduce:

  • Use Firefox 46.0.1
  • Setup WordPress in Greek
  • Visit WP Dashboard

You should be able to notice the attached Warning.

( ! ) Warning: sprintf(): Too few arguments in /www/wpbeta.dev/wp-admin/includes/dashboard.php on line 1444

Change History (3)

#1 @tobifjellner
21 months ago

  • Resolution set to invalid
  • Status changed from new to closed

This is due to an incorrect translation in the Greek version.

It looks like you're using an insecure version of %s. Using an outdated browser makes your computer unsafe. For the best WordPress experience, please update your browser.

Has been translated into Greek as

Φαίνεται ότι χρησιμοποιείτε μια μη ασφαλή έκδοση του <a href='%s'>%s</a>. Η χρήση παρωχημένων πλοηγών καθιστά μη ασφαλή τη χρήση του υπολογιστή σας. Για να απολαμβάνετε καλύτερα το WordPress, παρακαλούμε αναβαθμίστε τον πλοηγό σας.

As you can see, the translation contains one more instance of %s than the source string.

Thanks for your report. Since this is not a bug in WordPress core, I'll close this ticket, but I'll write a notice at https://make.wordpress.org/polyglots for the Greek translation editors to correct this.

If you know Greek well, then you yourself may suggest a correct translation at https://translate.wordpress.org/projects/wp/dev/admin/el/default?filters%5Bstatus%5D=either&filters%5Boriginal_id%5D=20657&sort%5Bby%5D=translation_date_added&sort%5Bhow%5D=asc

#2 @kosvrouvas
21 months ago

Hey everyone! I fixed this. Thank you Dimitris Mitsis!

#3 @netweb
21 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.