WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 20 months ago

Last modified 19 months ago

#42858 closed enhancement (duplicate)

Minimum PHP version requirement for upgrading to WordPress 5.0

Reported by: ottok Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

The WordPress installer (and upgrader) should check that the system has at least PHP 5.3 available, and refuse to install/upgrade to WordPress 5.0 if the PHP version is older than 5.3.

Such a hard requirement would be semantically correct in conjunction of the release of WordPress 5.0.

This change would affect the current 3.7 % of users still on PHP 5.2.

Users running PHP 5.2 or older would be left to using WordPress 4.9.x branch, which is likely to be maintained for a long time and thus still a valid WordPress version to use for a long time.

Developers of core would be allowed to use features available since PHP 5.3 from WP 5.0 onwards.

We suggest specifically PHP 5.3 since that version is still supported and security patched by a major Linux vendor (in CentOS/RedHat 6 series). Thus PHP 5.3 can still be a perfectly valid option to somebody. However, anybody running PHP 5.2 or older is most likely running an outdated Linux distribution that can have major security issues all over in PHP, Apache/Nginx, MySQL etc on that machine, and use of such machines should be strongly discouraged.

When releasing WordPress 6.0 we can maybe bump the requirement to PHP 7.0 depending on what the major Linux distributions are still supporting at that time. Anyway, the same code that is created now can be reused later on.

If the developers working on Gutenberg say they have or intend make braking changes that are incompatible with old WordPress environments, we could even consider having PHP 7.0 as the minimum requirement for WordPress 5.0 onwards, and thus we would indirectly protect old WordPress environments from breaking, as they would not upgrade to the 5.x releases because of this restriction, but remain using 4.9.x. This would nicely align with user and developer expectations related to a major release like 5.0 with Gutenberg.

The topic of WordPress PHP requirements has been discussed in many issues already. This new issue was made with the purpose of being very short, specific and actionable, and it can be either dismissed or closed with a single code commit in core. Most importand related issues are #33381 and #41191. Please don't close this issue as a duplicate. Only close this issue with a yes or no decision.

We intend to champion this idea in next WP PHP meeting.

If this issue is blessed, we are willing to create the code that implements it in WP core.

Issue filed by @drivingralle and @ottok on contributor day in WC Athens 2017.

Change History (8)

#1 @pento
20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thank you for the ticket, @ottok!

#33381 and #41191 continue to be the existing plan for bumping the minimum PHP version, there's no intention to bump it in conjunction with WordPress 5.0 at this stage.

#2 @Drivingralle
20 months ago

@dd32 can you post the percentages of WordPress versions within the PHP 5.2 users from the stats collected by .org.

Thanks.

#4 @Drivingralle
20 months ago

@Presskopp I mean more like all users of PHP 5.2:
WP 4.9: x%
WP 4.8: x%
WP 4.7: x%
WP 4.6: x%
WP 4.5: x%
WP 4.4: x%
WP 4.3: x%
[...]

This ticket was mentioned in Slack in #core-php by otto. View the logs.


20 months ago

#6 @ottok
20 months ago

Current behavior (since support for PHP 4 was dropped) is that WordPress allows users to install/upgrade, but when they run WordPress, it just says

Your server is running PHP version 4.4.9-nfsn1 but WordPress 3.2.1 requires at least 5.2.4.

Instead of just increasing this "requires at least ..." version, we would prevent users from upgrading their still working 4.9.x WordPress to 5.0.

#7 @ottok
20 months ago

This was discussed in #core-php meeting on 2017-12-11 and did not gain support from core devs, so closing issue.

There is no point in investing contributors' time on this since there are no sponsors inside core/Automattic who could consider merging the code. Currently core people are interested in reviewing/merging only contributions related to #33381 and #41191.

#8 @pengriffix
19 months ago

Hello, i just upgraded to 5.0 and my blog (https://ireportdaily.com) got slow.

Note: See TracTickets for help on using tickets.