WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4286 closed enhancement (duplicate)

Move drafts to their own page

Reported by: devil1591 Owned by: rob1n
Milestone: Priority: normal
Severity: normal Version: 2.2
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

I the admin, when you have like 10 drafts, the current list, comma separated is hugly and not easy to read...

This patch makes a <ul> list instead of this and I think this is easier to read!

Attachments (2)

edit.patch (1.7 KB) - added by devil1591 8 years ago.
4286.diff (4.7 KB) - added by rob1n 8 years ago.

Download all attachments as: .zip

Change History (15)

@devil15918 years ago

comment:1 follow-up: @rob1n8 years ago

  • Keywords 2nd-opinion added

Making it a <ul> was suggested and I coded it up before for another ticket, but I don't think it's the best way to show it. Though I'm not sure what's better -- a comma-separated list, a <ul> or something else...

comment:2 in reply to: ↑ 1 @devil15918 years ago

with the comma-separated list, I really can't read 10 titles. I don't know if the <ul> is the best but the comma-separated list is not good enough...

comment:3 @rob1n8 years ago

  • Version changed from 2.3 to 2.2

comment:4 @intoxination8 years ago

The problem I see with using UL is that people who have a lot of drafts will have to scroll down a lot to get to published drafts.

Instead of just doing a patch on the way the current system appears, I would much rather see Drafts get their own sub-menu page. This is something that is long overdue.

comment:5 follow-up: @devil15918 years ago

Sorry but I don't like the idea of moving drafts to another sub-menu page...
Drafts are on the top of the page because you need to publish or delete them soon.

If users have tons of drafts, they should delete or publish them.

The <ul> list is better for Web Accessibility too.

comment:6 in reply to: ↑ 5 @intoxination8 years ago

Replying to devil1591:

Sorry but I don't like the idea of moving drafts to another sub-menu page...
Drafts are on the top of the page because you need to publish or delete them soon.

If users have tons of drafts, they should delete or publish them.

The <ul> list is better for Web Accessibility too.

Sorry but I strongly disagree. People use their drafts for different purposes and I don't think it applies to the user friendly atmosphere of Wordpress to keep not handle better management of drafts because "users should delete or publish them".

Also we see more sites going to group blogging off of Wordpress. If an admin or editor currently wants to clean out drafts, they have to click on each one and see who wrote it, when and decide what to do from there. You also get contributors on sites that can't publish and their posts become lost in a mess of drafts.

A better draft management system is also a one of the highest rated ideas to extend Wordpress:

http://wordpress.org/extend/ideas/?show=popular

IMHO I got to give changing the current lists to an unordered list on the same page a -1. There has been a lot of talk about changing the handling of drafts and if do this patch, even temporarily, people might think this is all that was done to enhance drafts.

Just my 2 cents.

comment:7 @devil15918 years ago

Sorry, I agree the fact that we can't oblige people to "delete or publish". I realized this with this screenshot http://www.ektoplazm.com/img/drafthell.jpg !

Well, we need to find something better, because the comma-list is hugly, and the unordered list is not good enough !

comment:8 @rob1n8 years ago

  • Keywords has-patch 2nd-opinion removed
  • Owner changed from anonymous to rob1n
  • Status changed from new to assigned
  • Summary changed from Better draft list in wp-admin/edit.php to Move drafts to their own page

I've got some ideas for this.

comment:9 @rob1n8 years ago

  • Keywords has-patch added

Okay, that patch does the following things:

  • Create a new Drafts submenu page under Manage.
  • When there are more than 2 drafts, show a link to the Drafts page anyways.

@rob1n8 years ago

comment:10 @rob1n8 years ago

Okay, new patch, tested, seems fine.

comment:11 @rob1n8 years ago

  • Status changed from assigned to new

comment:12 @ryan8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3945, which is fixed in 2.3.

comment:13 @Nazgul8 years ago

  • Milestone 2.3 deleted
Note: See TracTickets for help on using tickets.