WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#42876 closed defect (bug) (wontfix)

Bug in wordpress editor

Reported by: hemrajrs Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: Editor Keywords:
Focuses: Cc:

Description

Hi there,

I found one issue in wordpress visiul editor, when we copy text from ms word, like

  1. williams

Editor converts it to

  1. Williams,

Please check

Attachments (2)

tinyeditor.PNG (16.4 KB) - added by hemrajrs 3 years ago.
msword.PNG (32.0 KB) - added by hemrajrs 3 years ago.

Download all attachments as: .zip

Change History (3)

@hemrajrs
3 years ago

@hemrajrs
3 years ago

#1 @dd32
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Hi @hemrajrs and welcome to Trac.

This appears to be due to a shortcoming of pasting content from Word. The browser doesn't get any markup which allows the editor to know what the source content is. "j. williams" matches the format of a list so is assumed to be a list.

You can change this by changing WordPress to "paste as text", which in the standard WordPress editor on the second line, I'll upload an image of that shortly, but you don't appear to be using the standard WordPress editor, so I can't tell if this response even applies to your case.

I'm closing this as wontfix as although it's annoying, it's working as intended currently. The behaviour might change in WordPress 5.0 with Gutenberg.

Reference for others:
https://core.trac.wordpress.org/browser/trunk/src/wp-includes/js/tinymce/plugins/paste/plugin.js?marks=907-929#L900

Note: See TracTickets for help on using tickets.