WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 2 months ago

#42884 closed defect (bug) (duplicate)

plugin.php on line 600

Reported by: traveltimingsin Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: General Keywords:
Focuses: Cc:

Description

On my website, I'm seeing error below:

"Warning: Parameter 1 to wp_default_styles() expected to be a reference, value given in /home/bots/public_html/traveltimings/wp-includes/plugin.php on line 600"

How to remove this, any steps?

Change History (3)

#1 @Ipstenu
2 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Sadly this means that a plugin you're using is calling wp_default_styles incorrectly.

You'll want to start debugging by turning off all your plugins and see if it goes away.

If you need more help, please post in the forums here: https://wordpress.org/support/forum/how-to-and-troubleshooting/

#2 @obenland
2 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I've gotten that too on some older test installs of mine. It seems to be a PHP 7.1 problem that occurs when core runs the wp_default_styles and wp_default_script actions. In my case it was a 4.5.12 installation on 7.1.8.

Maybe @jrf @johnbillion or @pento can help fix that?

Last edited 2 months ago by obenland (previous) (diff)

#3 @ocean90
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

This is a duplicate of #37772 and was fixed by [38571]. Only 4.7+ is compatible with PHP 7.1.

Note: See TracTickets for help on using tickets.