WordPress.org

Make WordPress Core

Opened 22 months ago

Closed 22 months ago

Last modified 11 months ago

#42939 closed defect (bug) (worksforme)

4.9.1 Category issues

Reported by: scollett72 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.1
Component: Rewrite Rules Keywords:
Focuses: Cc:
PR Number:

Description

Since updating to 4.9.1, my site's category links no longer work. I have verified that it was this update that caused the issue. I had a copy of the site on Staging prior to the update and the category links work fine. I updated the staging site to 4.9.1 and the category links no longer worked. Then I reverted it back again and they worked again.

I have also gone through and deactivated plugins one by one and nothing made a difference. The only change that made any difference was the 4.9.1 update.

What happens is that we get a 404 error when we go to any of our category pages. Example: https://scubadiverlife.com/category/blog/news/

for comparison, this is the staging site without the 4.9.1 update.
http://sdl2014.staging.wpengine.com/category/blog/news/

Change History (3)

#1 @dd32
22 months ago

  • Component changed from General to Rewrite Rules
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hey @scollett72 and welcome to Trac.

Unfortunately this doesn't appear to be a WordPress bug at first, however there isn't enough details to pinpoint the issue.

My best guess is that there's something happening in your environment upon upgrade to cause the rewrite rules to be lost, this isn't the first type of this kind of report i've seen for WPEngine hosted sites - I'd suggest you contact them for support in this instance.
However, you may find that visiting the Options -> Permalinks page and clicking save may recreate the rules correctly.

I'm closing this ticket as worksforme as this doesn't appear to be a WordPress 4.9.1 issue - if WPEngine (or you) can pinpoint how/why this is WordPress's issue, please re-open with further details.

#2 @scollett72
22 months ago

Well, what further information do you need to help pinpoint it as a Wordpress issue. I'm happy to provide you with any additional information, access to the site, etc, since this is a HUGE problem for us and we can't figure out how to fix it. Without the 4.9.1 upgrade, things work fine. With it, things do not work fine. The only way I can see around the issue right now is to revert the entire site to 3 days ago before the upgrade occurred.

My .htaccess file says the rewrite rules are on. This is the exact same information that was in the .htaccess file prior to the upgrade to 4.9.1

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

#3 @awardpress
11 months ago

not sure if it is related, but i've just faced a similar bug, but this time it reproduces on a brand-new wordpress instance, empty fresh installation, thus, this time no one will say "Unfortunately this doesn't appear to be a WordPress bug". i also described a workaround there, if you're interested, visit https://core.trac.wordpress.org/ticket/45393

in my specific case, the category was empty, but it also works the same with non-empty categories

Last edited 11 months ago by awardpress (previous) (diff)
Note: See TracTickets for help on using tickets.