WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#43014 closed defect (bug) (duplicate)

WP-admin last modified showing future dates

Reported by: piyopiyofox Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.1
Component: Date/Time Keywords: has-patch needs-testing
Focuses: ui Cc:

Description

Hiya, I got rerouted here: We've recently found that in the wp-admin, the last modified dates act strange with drafts of pages and posts. In the new editor this is ok because there are separated tabs for scheduled posts and such, but the wp-admin gets confusing when you set a schedule date for a draft of a page or post. Essentially, that scheduled date becomes the "last modified" date.

Steps to reproduce
Starting at URL: example.wordpress.com/wp-admin
Create a page or post
Set the scheduled date and save as draft
What I expected
The "Last modified" area should show today's date

What happened instead
The "Last Modified" area shows the scheduled date

Browser / OS version
Chrome Version 63.0.3239.84 (Official Build) (64-bit) / MacOS 10.13.2 (17C88)

Screenshot / Video
Post date ref: https://cloudup.com/cfQTUARop0k
Page date ref: https://cloudup.com/cPA2vuX4ZqA

It looks like this issue was reported 3 years ago here: https://core.trac.wordpress.org/ticket/32386

Any update on this? :)

Attachments (1)

43014.patch (600 bytes) - added by Junaidkbr 4 years ago.
Fixes scheduled drafts

Download all attachments as: .zip

Change History (4)

#1 @Junaidkbr
4 years ago

Hi @piyopiyofox,

Welcome to WordPress Core and thank you for reporting this bug.

I was able to reproduce the bug using 5.0-alpha-20180103.053347.

@Junaidkbr
4 years ago

Fixes scheduled drafts

#2 @Junaidkbr
4 years ago

  • Keywords has-patch needs-testing added

#3 @swissspidy
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Since this was already reported in #32386, it makes sense to keep the discussion at one place instead of opening a new ticket for it.

Feel free to upload any patches there, but it's also worth reading that ticket's history to learn why it hasn't been fixed already. It seems to be more complex than initially thought by the contributors.

Note: See TracTickets for help on using tickets.