WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#43038 closed enhancement (duplicate)

Conditionally define temporary directories

Reported by: Clorith Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: has-patch
Focuses: Cc:

Description

Unit-tests currently make use of the /tmp/ directory for things like media files in various places.

Not all systems have their temporary directory defined in such a way, in my case on a Windows system.

By providing a new DIR_TEST_TMP constant we can conditionally set the temporary path in bootstrap.php and allow tests to be ran more reliably on other systems as well.

This of course includes updating existing tests with the /tmp/ path hardcoded to be updated to reflect the new constant.

Attachments (1)

43038.patch (8.0 KB) - added by Clorith 2 years ago.

Download all attachments as: .zip

Change History (3)

@Clorith
2 years ago

#1 @netweb
2 years ago

Related, possible duplicate of #39975?

#2 @Clorith
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

You are absolutely right, my Google-fu has failed me :)

Duplicate of #39975

Note: See TracTickets for help on using tickets.