WordPress.org

Make WordPress Core

#43057 closed defect (bug) (worksforme)

Blank space is display at tight side after adding text in visual composer

Reported by: nilamacharya Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.1
Component: Editor Keywords:
Focuses: ui Cc:

Description

Steps:

  1. Navigate to admin side and create any page/post
  2. Add some text in Visual composer

Issue: Text is left aligned and too much blank white space is display at right side.

Note: same issue for page/post

Attachments (2)

page.png (169.3 KB) - added by nilamacharya 17 months ago.
post.png (183.1 KB) - added by nilamacharya 17 months ago.

Download all attachments as: .zip

Change History (4)

@nilamacharya
17 months ago

@nilamacharya
17 months ago

#1 @swissspidy
17 months ago

The width of the editor is adjusted to the contend width set by themes so the preview better matches the front end. That's not a bug.

If you prefer 100% width, you could add a custom editor stylesheet to override these styles.

#2 @azaozz
17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

As swissspidy points out, this is a feature, not a bug. Have a look at that post on the front-end :)

You can override it by adding another rule in your theme's editor-style.css but I'd advise against it. The theme width also affects images, embeds, and other resizable elements and you won't be able to preview them well if you make the editor display at 100% width.

Note: See TracTickets for help on using tickets.