WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#43094 closed enhancement (duplicate)

Update the "Updates" screen

Reported by: johnjamesjacoby Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Administration Keywords:
Focuses: Cc:

Description

The plugin and theme updates screen (located at wp-admin/update-core.php) is starting to show its age. Now that pretty AJAX plugin and theme updates are in, maybe we can circle back and give some TLC to the unpretty updates screen.

Attachments (1)

pt-updates.mov (7.8 MB) - added by johnjamesjacoby 3 years ago.
Video of what updating core themes the old way has looked like since around 2.5 (or before)

Change History (6)

@johnjamesjacoby
3 years ago

Video of what updating core themes the old way has looked like since around 2.5 (or before)

#1 @johnjamesjacoby
3 years ago

A few specific things I don't like about the old process:

  • No check-boxes are checked by default. I'm a dummy and almost always click the button without checking any boxes at least once. It's the only thing I'm there to do, and the default action doesn't do anything without additional interaction. I think we should make users uncheck what they aren't ready for, instead of checking what they are.
  • Once the update request is sent off, there's a long period of time where there's literally nothing displayed to the user at all. I think this is a great place for a progress bar to show that the process is still alive.
  • Once the requested updates are complete, the details of each plugin/theme that were updated are just paragraphs of text underneath a bunch of notices. It's not great looking, and seems like the wrong UI elements in the wrong places. There's a lot we can do to make this better, and lots of good examples in the wild to be inspired by.
  • I think the "Return to" links are backwards. Generally, I want to return to the updates page to confirm that WordPress also thinks there is nothing left to update; if I wanted to leave the updates page, that's easy enough to do without having a dedicated link for it there. This is because software updates around the world on all platforms are unreliable, and my confidence in them is low, so I want to verify the work was completed correctly before I move onto other tasks.
Last edited 3 years ago by johnjamesjacoby (previous) (diff)

#2 @johnjamesjacoby
3 years ago

A few suggestions on how I think we can improve this screen:

  • Straight up copy the work from pretty updates and plunk it in here
  • Design a new and fancy user experience for this unique and commonly visited page
  • Reimagine this screen as an "Update Center" with user confidence building as a priority

Stretch goals:

  • Allow third party plugin & theme locations to filter more pieces to extend it more easily
  • Split this screen up into 3 (or more) sections for core, plugins, and themes
  • Consider moving the admin menu item back to under Tools (separate but related discussion)

#3 @swissspidy
3 years ago

We did some work on the Updates page as part of the Shiny Updates feature project. There's already #31531 to track enhancements on that page, thus I'm tempted to close this one as a duplicate. See also https://github.com/obenland/shiny-updates/issues/291.

The previously proposed enhancements to that particular page were ultimately not accepted for merge. The consensus was that it needed some more work.

If you're interested you're more than welcome to contribute to that feature project. Perhaps we could revive efforts on Shiny Updates v3.

#4 @johnjamesjacoby
3 years ago

I forgot the name of the feature, couldn't find #31531, and honestly didn't think to check GitHub or Make.

OK to close this; sorry for the noise.

#5 @dd32
3 years ago

  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Lets close this as a duplicate of #31531 - @johnjamesjacoby if you could post any thoughts over there, that'd be great.

Note: See TracTickets for help on using tickets.