WordPress.org

Make WordPress Core

#43135 closed defect (bug) (duplicate)

Remove deprecated "es3" from .jshintrc file.

Reported by: aristath Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Build/Test Tools Keywords:
Focuses: Cc:
PR Number:

Description

es3 has been deprecated in .jshintrc: http://jshint.com/docs/options/#es3
We should instead use "esversion": 3.

However, since WordPress no longer supports IE 6/7/8/9, ES3 is no longer necessary.
Perhaps we could up it to 5?

Attachments (2)

esversion3.diff (297 bytes) - added by aristath 23 months ago.
patch for "esversion": 3
esversion5.diff (297 bytes) - added by aristath 23 months ago.
patch for "esversion": 5

Download all attachments as: .zip

Change History (3)

@aristath
23 months ago

patch for "esversion": 3

@aristath
23 months ago

patch for "esversion": 5

#1 @netweb
23 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the ticket and suggestions @aristath, I'm going to close this as a duplicate of #28236, technically it's not a duplicate of that ticket as it currently only references onevar and trailing being deprecated...

I'm doing it this way because we're about to remove JSHint entirely via #42850 for WordPress 4.9.3 due to its "non-free license", as part of the removal of JSHint we will be switching to ESLint in #31823

Note: See TracTickets for help on using tickets.