WordPress.org

Make WordPress Core

Opened 21 months ago

Closed 9 months ago

#43138 closed defect (bug) (duplicate)

Deleting intermediate image-sizes with non-ASCII file-names

Reported by: idofri Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:
PR Number:

Description

Deleting attachments intermediate image-sizes often fails in some cases where file-names are constructed with multibyte character path names.

The bug is caused when using the basename() function without setting UTF-8 locales first. It has been documented in: https://bugs.php.net/bug.php?id=62119

This patch fixes only A single instance of the described issue and should be examined more widely.

Attachments (1)

43138.patch (777 bytes) - added by idofri 21 months ago.

Download all attachments as: .zip

Change History (5)

@idofri
21 months ago

#1 @idofri
21 months ago

  • Component changed from General to Media
  • Summary changed from Delete intermediate image-sizes with non-ASCII file-names to Deleting intermediate image-sizes with non-ASCII file-names

#2 follow-up: @Viper007Bond
21 months ago

This patch fixes only A single instance of the described issue and should be examined more widely.

I've made a bigger ticket for this as I ran into this same issue elsewhere: #43170

#3 in reply to: ↑ 2 @idofri
21 months ago

I've made a bigger ticket for this as I ran into this same issue elsewhere: #43170

+1

#4 @pento
9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version trunk deleted

Duplicate of #43170.

Note: See TracTickets for help on using tickets.