Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#43166 closed defect (bug) (worksforme)

4.9 broke uploaded images' paths on my network installation

Reported by: pasqal's profile pasqal Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: General Keywords:
Focuses: multisite Cc:

Description (last modified by desrosj)

I run a network installation. I upgraded from 4.8.2 to 4.9 back in December but found out that images were broken on all of my network's sites.

My network's sites are as follows:

Site 1: https://www.mybrand.com/es/blog/
Site 2: https://www.mybrand.com/en/blog/
Site 3: https://www.mybrand.co.uk/en/blog/
Site 4: https://www.mybrand.it/it/blog/
etc.

4.9 converts a 4.8.2 working image URL on Site 1, such as:
https://www.mybrand.com/es/blog/wp-content/uploads/sites/1/2016/09/image.jpg

...into the following non-existent URL:
https://www.mybrand.com/es/blog/wp-content/uploads/2016/09/image.jpg

... thus resulting in a 404 response for the image load.

Since I had upgraded some plugins together with the WordPress core, what I tried first was deactivating those, with no success. So I ended up downgrading the core back to 4.8.2, which fixed the bug.

Last week I again tried upgrading to 4.9.2, with the same result (the image bug is still there). This time I downgraded to 4.8.5, which works fine.

All sites use the Twenty Sixteen template.

My current install includes the following plugins at the network level:

  • AddToAny Share Buttons Version 1.7.23
  • All In One SEO Pack Version 2.4.4.1
  • Autoptimize Version 2.3.2
  • Broken Link Checker Version 1.11.5
  • Custom Meta Widget Version 1.4.8
  • Custom Permalinks Version 1.2.12
  • Customize Login Image Version 3.3.1
  • Disable REST API Version 1.4.2
  • External Links Version 6.8.1
  • Google Analytics for WordPress by MonsterInsights Version 6.2.7
  • Google Captcha (reCAPTCHA) by BestWebSoft Version 1.33
  • HREFLANG Tags Lite Version 1.5.6 | By DCGWS
  • Jetpack by WordPress.com Version 5.7.1
  • kk Star Ratings Version 2.6
  • Simple 301 Redirects Version 1.07
  • W3 Total Cache Version 0.9.6
  • wBounce Version 1.8
  • WordPress Importer Version 0.6.3
  • WP Downgrade Version 1.1.4
  • WP Login Flow Version 1.0.0
  • WP Rollback Version 1.5

I actually installed WP Downgrade and WP Rollback after 4.9 broke my installation, to help downgrade to a working version.

All templates and plugins are up to date.

Change History (3)

#1 follow-up: @abdullahramzan
6 years ago

  • Keywords close added

Hello @pasqal ,

Please deactivate the plugins one by one and then check which plugin is conflicting with your WordPress and then contact the plugin author or reach them on its support forum.

Thanks

#2 in reply to: ↑ 1 @pasqal
6 years ago

Replying to abdullahramzan:

Hello @pasqal ,

Please deactivate the plugins one by one and then check which plugin is conflicting with your WordPress and then contact the plugin author or reach them on its support forum.

Thanks

Hello @abdullahramzan,

Already tried that, and it did not work.

Thanks!

#3 @desrosj
5 years ago

  • Description modified (diff)
  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hi @pasqal,

Sorry that this ticket fell through the cracks.

Are you still experiencing this issue on your sites? Since I was unable to locate any similar reports for this issue and I am unable to reproduce, I am going to close this one out.

If you are still experiencing the issue, I recommend creating a support ticket in the WordPress.org support forums to debug further.

Note: See TracTickets for help on using tickets.