WordPress.org

Make WordPress Core

#43179 closed defect (bug) (invalid)

News and events meta box not accurate on location

Reported by: danieltj Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.2
Component: Administration Keywords:
Focuses: administration Cc:
PR Number:

Description

I live in Essex, United Kingdom so when I enter Essex into the nearby events meta box, I'd expect to get at least events near-ish London if nothing closer is available.

However I seem to be getting results in the US. Essex is a rather large (one of the largest I believe) county in the UK so there should be at least some activity to report on nearby. Like I mentioned, it's close enough that results in London would be semi-appropriate.

I'm assuming the geolocation is off somehow?

Change History (1)

#1 @dd32
21 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

The issue is that we're doing geolocation based on cities, not counties or states/territories.

As such, Essex doesn't exist in our dataset for UK, only the US cities of the same name.

Meetup events in a 40km radius (Well, boxed radius) are shown based off the result, so in the case of Essex, searching for say Chelmsford results in events from Cambridge, Maidstone, London, etc. https://api.wordpress.org/events/1.0/?location=Chelmsford

As this is to do with the Events API, this would be better reported on meta.trac.wordpress.org in the API component - there's a number of existing tickets related though: https://meta.trac.wordpress.org/query?status=!closed&component=API (but none about counties).
One of the issues with Counties is that our current "xKM from point X,Y" won't work with them, a town on the edge of two counties but too far from the center point might not get included when the user is only minutes from it for example.

I'm going to close this ticket as invalid, however please feel free to open a meta.trac ticket or include it on one of these perhaps:
https://meta.trac.wordpress.org/ticket/3367
https://meta.trac.wordpress.org/ticket/2998
https://meta.trac.wordpress.org/ticket/2823

Note: See TracTickets for help on using tickets.