WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#4318 closed defect (bug) (duplicate)

wp-mail.php not functioning

Reported by: rob1n Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2.2
Component: Administration Keywords:
Focuses: Cc:

Description

As mentioned by dmd on IRC -- after upgrading to 2.2, wp-mail is broken (only title, no body), but substituting the old wp-mail.php works fine. Diff attached.

I'm thinking the Content-transfer-encoding part.

Attachments (2)

wp-mail.diff (1.5 KB) - added by rob1n 7 years ago.
PN_mailfix.php (2.7 KB) - added by morty 7 years ago.
My Plugin for fixing the wp-mail problem

Download all attachments as: .zip

Change History (16)

rob1n7 years ago

comment:1 rob1n7 years ago

  • Milestone changed from 2.2.1 to 2.3

Okay, he narrowed it down to something in class-pop3.php.

comment:2 cfactor7 years ago

As far as I can tell, this cannot be fixed by modifying wp-mail. I attached "what-works-for-me" patch of class-pop3.php patch to ticket #4337. Please look over it and see if it does things properly.

comment:3 follow-up: cfactor7 years ago

  • Cc cfactor added

comment:4 in reply to: ↑ description ; follow-up: morty7 years ago

It's the encoding. I already wrote a patch for my plugin.

morty7 years ago

My Plugin for fixing the wp-mail problem

comment:5 in reply to: ↑ 4 cfactor7 years ago

Replying to morty:

It's the encoding. I already wrote a patch for my plugin.

morty, this ticket is for when posting via e-mail. I don't think it has anything to do with wordpress *sending* emails.

comment:6 in reply to: ↑ 3 ; follow-up: lexhair7 years ago

Replying to cfactor:Please consider adding a check box switch to the Blog by Email admin panel to dump emails that come from addresses not in the user database. I believe the wp-mail.php code must be user modified for this functionality. Should this be a separate enhancement request?

comment:7 in reply to: ↑ 6 ; follow-up: Nazgul7 years ago

Replying to lexhair:

Should this be a separate enhancement request?

Yes, please create a new enhancement request for that. One issue per ticket, to avoid confusion.

comment:8 in reply to: ↑ 7 lexhair7 years ago

Replying to Nazgul:

Replying to lexhair:

Should this be a separate enhancement request?

Yes, please create a new enhancement request for that. One issue per ticket, to avoid confusion.

Done. Thank you for the quick response.

comment:9 follow-up: dmd7 years ago

  • Milestone changed from 2.3 (trunk) to 2.2.3

There's absolutely no reason why this patch can't be applied for 2.2.3.

1) This is core functionality which used to work, and got broken.

2) The patch changes only one file, wp-mail.php - a file which currently has NO functionality due to this defect.

3) wp-mail.php is used by no part of wordpress other than this functionality. The only possible effect of applying this patch is a change to this functionality - either it will start working again, or it won't. It can't break anything else.

4) It does, in fact, cause wp-mail to start working again.

comment:10 in reply to: ↑ 9 foolswisdom7 years ago

  • Version set to 2.2.2

Replying to dmd:

There's absolutely no reason why this patch can't be applied for 2.2.3.

dmd, the milestone process isn't formalized well. Often things get committed to trunk, tested, and then committed to the maintenance branch.

comment:11 foolswisdom7 years ago

  • Milestone changed from 2.2.3 to 2.3

comment:12 follow-up: shadowdad7 years ago

New to WP. I would be happy to provide additional testing on this patch, havejust been down the rat-hole of trying to get post by mail to work. I have found another bug (footer email activation doesn't seem to work with Firefox) which i can test with the this fix and see if it is an independent bug (likely) but might as well check before entering. please provide pointer to fixed, i would like to be moving code forward, currently am using the 2.1.3 class-pop3.php and wp-mail.php to get around problem.

comment:13 in reply to: ↑ 12 cfactor7 years ago

Replying to shadowdad:

please provide pointer to fixed

I still believe this cannot be fixed by patching just wp-mail.php, as class-pop3.php will pass it blank body content. Please look at ticket 4337. Be sure to use only one or the other. Nazgul's 4337.diff is more elegant than my class-pop3.php.patch, but Nazgul's patch will add an extra blank line to the end of the post. This may or may not concern you. I have not had the time to fix his patch to take care of the extra blank line.

comment:14 Nazgul7 years ago

  • Milestone 2.3 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4337.

Note: See TracTickets for help on using tickets.