WordPress.org

Make WordPress Core

Opened 21 months ago

Last modified 15 months ago

#43206 reopened defect (bug)

Angle brackets around URLs can confuse email clients

Reported by: tomdxw Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.9.2
Component: Mail Keywords:
Focuses: Cc:
PR Number:

Description

In #14140, angle brackets were added to plain text emails sent by WordPress due to some email clients not handling long URLs correctly.

However in some email clients, the trailing > is treated as part of the link, which also causes users to end up at the wrong URL.

As there is no standardised way to make a link clickable in a plain text document I think the best solution would be for WordPress to send all mail in both text/plain and text/html.

Change History (6)

#1 @swissspidy
21 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23578.

#2 @tomdxw
21 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Sorry, this is not the same issue.

#23578 is asking for retrieve_password() to change its behaviour based on the output of the wp_mail_content_type filter. This would allow people running WordPress sites to force WordPress to send plain text emails as HTML.

This ticket is asking for retrieve_password() (and other functions that send emails with links) to send a multipart email with a text/plain part and a text/html part. This would fix a problem with email clients trying to guess where links are and failing (or at least it would fix it for people using email clients which support HTML).

#3 @SergeyBiryukov
21 months ago

Related: #18493, #21095, #23420, #39742.

The latest patch on #23578 changes wp_mail() to convert URLs in brackets to proper links if wp_mail_content_type is set to text/html, I think that would be a good first step.

Last edited 21 months ago by SergeyBiryukov (previous) (diff)

#4 @SergeyBiryukov
19 months ago

  • Milestone set to Awaiting Review

#5 @swissspidy
18 months ago

#43756 was marked as a duplicate.

#6 @SergeyBiryukov
15 months ago

#44589 was marked as a duplicate.

Note: See TracTickets for help on using tickets.