WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#43237 closed feature request (duplicate)

Categories Widget is not WCAG 2.0 accessible

Reported by: benjamingaunt Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Widgets Keywords:
Focuses: accessibility Cc:

Description

As a public university website mandated to achieve WCAG 2.0 accessibility standards, we've found that the Categories widget presents navigation issues when displaying categories in a dropdown selector.

The WCAG issue at hand is SC 3.2.1 On Focus, specifically that forms should not be submitted automatically when a component receives focus. This is what happens when using the Categories widget's dropdown selector.

For mouse users, the dropdown is a fairly intuitive process that involves simply clicking to expand the dropdown and then clicking to select a cateogory to explore. Clicking the category immediately opens a page populated by posts with that category.

For keyboard users, however, the dropdown is essentially unusable because it assumes that the user has selected the first category they pause on and immediately opens a page based on that. There's no way to scroll down the menu and see what the options are before making a selection.

WCAG standards require a "Submit" button or similar action to initiate that navigation to a new page, not simply resting the focus on a category.

Change History (6)

#1 @jorbin
4 years ago

  • Component changed from General to Widgets
  • Focuses accessibility added

This ticket was mentioned in Slack in #accessibility by williampatton. View the logs.


4 years ago

#3 follow-up: @afercia
4 years ago

@benjamingaunt thanks for your report and welcome to Trac! Seems to me this is about the same issue already tracked on #40925 which applies to a few places in core, for example: Categories and Archives widget, Media views "Filter by type" and "Filter by date" selects. See also #25103.

#4 in reply to: ↑ 3 @benjamingaunt
4 years ago

Replying to afercia: Thanks for pointing those out, yes it sounds like the same issue! I'll watch those tickets as well.

@benjamingaunt thanks for your report and welcome to Trac! Seems to me this is about the same issue already tracked on #40925 which applies to a few places in core, for example: Categories and Archives widget, Media views "Filter by type" and "Filter by date" selects. See also #25103.

#5 @benjamingaunt
4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #40925.

#6 @netweb
4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.