WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#4324 closed enhancement (duplicate)

Comment Meta Table

Reported by: technosailor Owned by: technosailor
Milestone: Priority: normal
Severity: normal Version: 2.3
Component: Optimization Keywords: comments meta
Focuses: Cc:

Description

I'd like to propose a comment meta table for WordPress 2.3. Functionally, the schema would mirror the postmeta table. This would allow plugin authors to classify comments in different ways. Initially, the upgrade should probably prepopulate the table with existing comment IDs withthe key/values from the post_type field in the comments table.

I can create this, but I'd like to get concensus and spec it out.

Change History (5)

comment:1 zamoose7 years ago

  • Version set to 2.3

+1 Consensus-building.

How about selling some of the advantages to this addition? What sort of stonkingly-cool stuff would this allow plugin and theme auths to develop (e.g. Jack Slocum's wicked <a href="http://www.jackslocum.com/blog/2006/10/09/my-wordpress-comments-system-built-with-yahoo-ui-and-yahooext/">comment annotation</a>, etc.)?

Just to make selling the sizzle all the easier, you understand.

comment:2 zamoose7 years ago

Shazbot. I should've previewed.

Apologies all around -- I seem to be making a habit of this behavior as of late.

comment:3 technosailor7 years ago

Heh.

Well, one example is a plugin I want to create that offers parallel comment streams. They "whys" regarding the reason why I'll leave to your imagination. However, the plugin could alter the table, create a new table or simply use a meta table. It makes the most sense for me that we use a meta table as many many different uses could be found.

comment:4 rob1n7 years ago

Would it make sense to just change things around to have one "meta" table? What are the advantages/disadvantages for that?

Just have a "meta" table with "type" set to "post" "link" "comment", "<custom>", etc.

comment:5 markjaquith7 years ago

  • Milestone 2.3 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2659 ... go add your +1s there!

Note: See TracTickets for help on using tickets.