Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#43245 closed defect (bug) (duplicate)

Bug with constant WP_ALLOW_REPAIR

Reported by: nicolaskulka's profile NicolasKulka Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.4
Component: Database Keywords:
Focuses: Cc:

Description

When the constant is set to false, repair and optimization database still works.

There is no verification of the value of the constant.

I tried setting the value to false, but the repair script still works.

Change History (5)

#1 @swissspidy
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #42622.

This was fixed in [42205].

Last edited 6 years ago by swissspidy (previous) (diff)

#2 @swissspidy
6 years ago

Duplicate of #42622.

#3 @NicolasKulka
6 years ago

Last edited 6 years ago by NicolasKulka (previous) (diff)

#4 @NicolasKulka
6 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

And also, why is there no check if the person who starts the repair is logged in?

#5 @swissspidy
6 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #42622.

This has been explained in another ticket, #11717. When the user table is broken and needs to be repaired, you can't check if someone is an admin. Also, it would unreasonably conflate DB admin and site admin roles. As such, the ticket was closed as wontfix.

If you disagree with that, you can leave a comment on that ticket. Note that discussions can happen on closed tickets too. If the pros outweigh the cons and there's a patch, we can of course reconsider #11717 and reopen it if necessary.

Note: See TracTickets for help on using tickets.