WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#43246 closed defect (bug) (duplicate)

Thumbnail creation removing other original attachment files

Reported by: remimodulo Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.4
Component: Media Keywords:
Focuses: Cc:

Description

How to reproduce bug :

  • Get any thumbnail size from your WordPress. For exemple : "150x150".
  • Upload a file with this size written in the file name : "test-150x150.png".
  • Upload an other file with the same name without the size : "test.png" (large enough that WordPress will try to create a thumbnail with the size you got early).

Result : the original file of the first media uploaded will be replaced by the thumbnail of the second (you might have to reload the page to see it in the media list).

First file to upload (wp-media-bug-150x150.png) :
https://www.remitoffoli.com/p/wordpress/wp-media-bug-150x150.png

Second file to upload (wp-media-bug.png) :
https://www.remitoffoli.com/p/wordpress/wp-media-bug.png

What it does... :
https://www.remitoffoli.com/p/wordpress/wp-media-bug.gif

Attachments (4)

wp-media-bug-150x150.png (7.8 KB) - added by remimodulo 3 years ago.
First file to upload
wp-media-bug.gif (365.8 KB) - added by remimodulo 3 years ago.
Second file to upload
wp-media-bug.2.gif (365.8 KB) - added by remimodulo 3 years ago.
What it does…
wp-media-bug.png (18.0 KB) - added by remimodulo 3 years ago.
The second file to upload (edit)

Download all attachments as: .zip

Change History (5)

@remimodulo
3 years ago

First file to upload

@remimodulo
3 years ago

Second file to upload

@remimodulo
3 years ago

What it does...

@remimodulo
3 years ago

The second file to upload (edit)

#1 @desrosj
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #42437.

Hi @remimodulo! Thanks for the detailed ticket, and welcome to trac!

There is a ticket for this problem already. Since there has been some conversation over there, going to close this out as a duplicate.

Note: See TracTickets for help on using tickets.