WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#4326 closed defect (bug) (invalid)

WP can't use Google Apps For Your Domain email accounts.

Reported by: PStamatiou Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: 2nd-opinion
Focuses: Cc:

Description

There's a good description of the issue here: http://wordpress.org/support/topic/118423?replies=3#post-563138

Change History (6)

comment:1 foolswisdom7 years ago

Paul, look else where tickets are sin.

Can you test to see if it is specific to Google hosted email?

Could this relate to #4318 ?

astorg writes on wp.org/support:

I had this problem too ever since I switched to Google Apps Hosted Gmail a few months ago (this was before 2.2). For a long time I wasn’t receiving any mail notifications and/or contact form mail.

I finally solved it with a combination of several steps to completely revamp the way WordPress handles email.

The first measure was installing the http://www.shiftthis.net/wordpress-swift-smtp-plugin/ plugin wish allows you to manage all your email using a secure connection via your Gmail SMTP server. This will work with Google Apps, but you need to tweak several of your PHP files and plugins that use email to make the switch functional (all explained on the plugin site). This got my contact form email back through.

A second, apparently unrelated problem was that WordPress doesn’t seem to like it if you post articles using the same email address as the one used for admin and the one used for the plugin. I solved this one by using one address for my profile (the one my posts are signed under) and another for (1) blog admin and (2) the SMTP plugin email address (the one that any incoming email to me from the contact form or the WordPress admin gets sent to.

I also got rid of the <wordpress@…> default address that the standard install will set up and replaced it with my admin address.

With these two additional steps, my comment and subscription notices started coming back through. It looks as if WordPress doesn’t like sending them to you if you are the author of the articles in your blog.

The final touch was to disable email on my Media Temple (DV) 3.0 server. Although my DNS isn’t managed by Media Temple, I noticed that this final step (which I had overlooked when I switched my email to Google Apps) finally got me receiving notifications about 404 Errors (which had previously got swallowed up by the system despite all the above fixes).

comment:2 rob1n7 years ago

  • Component changed from WordPress.org to General
  • Owner changed from matt to anonymous

(Note: WordPress.org is for the site)

I used to use Google Apps, and I never had any issues with it, but I only skimmed the forum post.

comment:3 Otto427 years ago

I use Google Apps for my Domain right now, and have no issues receiving email from Wordpress.

I would say to mark this as worksforme, because the problem is never *receiving* email, it's *sending* email. Wordpress can't control what the receiving side does, it just uses the built in PHP mail functions and sends it off. 2.2 did change to using the PHPMailer class, but it's still using mail() internally there. If your PHP is not configured correctly, then yeah, mail won't work, but what the receiving system is does not matter.

comment:4 MellerTime7 years ago

Sounds like the server WP is running on is still attempting to deliver emails for @domain.com locally, rather than actually looking at the MX record for the domain and sending it to the appropriate server. Most control panels have some sort of method for disabling email on a domain, which should free it up to look at DNS for the server.

In any case, I'd say this is not a WP bug, but a server config issue.

comment:5 markjaquith7 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Definitely a server config issue. WP sends mail via mail()

comment:6 markjaquith7 years ago

  • Milestone 2.4 (next) deleted
Note: See TracTickets for help on using tickets.