WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 2 years ago

#43262 closed defect (bug) (worksforme)

WordPress's Emoji Replacement Scheme Incorrectly Converts Glyphs, and Should Also Have an Off Switch

Reported by: paulkafasis Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.4
Component: Emoji Keywords:
Focuses: Cc:

Description

In recent WP versions (4.9.4, 4.9.3, maybe others), WP does some sort of conversion of emoji glyphs. Rather than using the OS's emoji, it seems a WP-based image is substituted. Two things:

1) Most importantly, this replacement is buggy. Something like ↩︎ is a two-part glyph, with the second part being a modifier that essentially says “Do NOT replace with emoji”. However, WP replaces the first part, and then renders the second part with an unknown glyph box. The end result is obviously broken.

2) Even if/when this is fixed, this should be a setting site owners can toggle off if they so choose. There are now plugins for this, but it should be part of WP itself.

Attachments (2)

ProperRendering.png (6.1 KB) - added by paulkafasis 4 years ago.
This is how ↩︎ should render.
WP-Failed-Rendering.png (6.5 KB) - added by paulkafasis 4 years ago.
This is the broken way WordPress 4.9.4 renders the glyph - an emoji, and an unknown box.

Download all attachments as: .zip

Change History (6)

@paulkafasis
4 years ago

This is how ↩︎ should render.

@paulkafasis
4 years ago

This is the broken way WordPress 4.9.4 renders the glyph - an emoji, and an unknown box.

#1 @swissspidy
4 years ago

  • Component changed from General to Emoji
  • Summary changed from WordPress's Emoji Replacement Scheme Incorrectly Converts Glyohs, and Should Also Have an Off Switch to WordPress's Emoji Replacement Scheme Incorrectly Converts Glyphs, and Should Also Have an Off Switch

#2 @redsweater
4 years ago

I confirmed that this bug is due to erroneous behavior of the twemoji.js script that WordPress bundles. Newer revisions to this script, for example the one here:

https://github.com/twitter/twemoji/blob/gh-pages/twemoji.js

Contain special consideration for the character in question, and leave examples like the one @paulkafasis cites in tact.

In short: the errenous replacement will be resolved by merging in a newer twemoji.js. The request to offer a switch to disable the Emoji replacement altogether should probably be opened as a separate issue.

#3 @Otshelnik-Fm
4 years ago

🤠 - this emoji (and more others) can not be downloaded from the https://s.w.org/images/core/emoji/ as .svg file
Bug in WordPress 4.9.3, 4.9.4

On 4.7.9 - works

upd: screens https://ru.wordpress.org/support/topic/%d0%bf%d0%be%d0%bb%d0%be%d0%bc%d0%b0%d0%bb%d0%b8%d1%81%d1%8c-emoji/

Version 1, edited 4 years ago by Otshelnik-Fm (previous) (next) (diff)

#4 @pento
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

This issue has been fixed by updates to the Twemoji library.

There's currently no plan to add a toggle for Twemoji support: installing a plugin is the appropriate method to turn it off.

Note: See TracTickets for help on using tickets.