WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#43264 closed defect (bug) (duplicate)

WordPress Emojis show up as browser fingerprinting and will be blocked in new versions of FireFox

Reported by: freethenation Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Emoji Keywords:
Focuses: Cc:

Description

The emojis show up as browser fingerprinting in several different browser extensions.

The issue lies in var d=k.toDataURL(); in the script block added by the emojis (block starts with window._wpemojiSettings).

Further, and more importantly, firefox is going to start prompting users when a page uses several methods associated with canvas fingerprinting (ref https://thehackernews.com/2017/10/canvas-browser-fingerprint-blocker.html).

Change History (1)

#1 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 4.9.3 deleted

Duplicate of #42428.

Note: See TracTickets for help on using tickets.