WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#43277 closed defect (bug) (invalid)

in 4.9.4 a lot of my images align left when they are supposed to align center

Reported by: ConsiderThis1 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.4
Component: Media Keywords:
Focuses: Cc:

Description

https://health-boundaries.com/fingernails-2/
The captions on my images align centered, but the images themselves align left. They were inserted to align centered. Some images align properly. I don't know why the others won't. They were fine before I changed to the new version 4.9.4. Could it be because I didn't use 4.9.3 first?
Karen Kline

Change History (1)

#1 @SergeyBiryukov
19 months ago

  • Component changed from General to Media
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @ConsiderThis1, welcome to WordPress Trac! Thanks for the report.

The images should align correctly if you add these styles in Appearance → Customize → Additional CSS:

.wp-caption img[class*="wp-image-"] {
	display: block;
	margin-left: auto;
	margin-right: auto;
}

It doesn't look the issue was caused by the upgrade, but rather by these styles missing in your theme. This Trac is used for enhancements and bug reporting for the WordPress core software, please try the support forums if you need any further help with your site.

Last edited 19 months ago by SergeyBiryukov (previous) (diff)
Note: See TracTickets for help on using tickets.