WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 6 months ago

#43338 closed defect (bug) (invalid)

Bug WordPress Multisite

Reported by: andreadelgrosso Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.4
Component: Editor Keywords: close
Focuses: multisite Cc:

Description

Hello,
I want to report a bug on WordPress Multisite. I'm using WordPress 4.9.4 version.

Using WordPress Multisite, if a administrator user or editor user click on an iframe in the visual editor view, and then click to CTRL+C or CMD+C or copy and then update page, this iframe disappear.

This doesn't happen if the same user is also a super admin.
Someone know where is the problem?

Thank you.

Change History (3)

#1 @danieltj
2 years ago

  • Keywords close added
  • Resolution set to worksforme
  • Status changed from new to closed

Hi, welcome to Trac!

This is because admins and editors on single site installs can post unfiltered HTML however these roles are considered not trustworthy on multi sites and so only super admins can post unfiltered HTML.

This working as designed in this instance. You’ll need to use a super admin account instead to paste the iframe content.

#2 @SergeyBiryukov
2 years ago

  • Focuses multisite added
  • Milestone Awaiting Review deleted
  • Resolution changed from worksforme to invalid

#3 @SergeyBiryukov
6 months ago

#48865 was marked as a duplicate.

Note: See TracTickets for help on using tickets.