WordPress.org

Make WordPress Core

Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#43340 closed defect (bug) (invalid)

Enable Copy and Paste without Unnecessary Dialog Messages

Reported by: terranese Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

  1. Copying and pasting should not require any permission messages let alone two dialog boxes:

Do you want to allow this web page to access your clipboard?
Please Use Ctrl+v/Cmd+v shortcuts to post content.


  1. Mouse/Insertion Point goes to bottom of (long) post instead of staying at the same place!
  1. The second dialog message is not true since I can do mouse right-click | option Paste as well.

Change History (5)

#1 @johnbillion
18 months ago

  • Component changed from General to Editor
  • Keywords reporter-feedback added
  • Type changed from enhancement to defect (bug)

Thanks for the report, @terranese .

Can you provide some more information please? This sounds like it might be caused by a plugin that alters the post editor, for example a page builder plugin.

Do the dialog messages still appear if you deactivate all your plugins and switch to one of the default themes (for example Twenty Seventeen)?

Which browser (including version) and operating system are you using?

Does the problem occur with both the "Visual" editor and the "Text" editor?

#2 follow-up: @terranese
18 months ago

Hello John,

I am using free theme Twenty Fourteen, so there are no additional plug-ins nor can I deactivate any.
I am using the Visual Editor running IE 11 on Windows 10.
I just tried the same copy=paste on MS Edge and there was no problem!!!

I just created a new page in IE 11 and there was no problem!!!

OK, so what changed?

#3 in reply to: ↑ 2 @terranese
18 months ago

Hi! I just realized the message was from IE. I googled the error message and found out that one has to enable copying from clipboard in IE | Internet Options | Security | Custom Level | Scripting | Allow programmatic clipboard access. Set to "Enable" instead of "Prompt". Restart IE.

Replying to terranese:

Hello John,

I am using free theme Twenty Fourteen, so there are no additional plug-ins nor can I deactivate any.
I am using the Visual Editor running IE 11 on Windows 10.
I just tried the same copy=paste on MS Edge and there was no problem!!!

I just created a new page in IE 11 and there was no problem!!!

OK, so what changed?

#4 @johnbillion
18 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the update!

#5 @SergeyBiryukov
18 months ago

  • Summary changed from Enable Copy and Paste without Unecessary Dialog Messages to Enable Copy and Paste without Unnecessary Dialog Messages
Note: See TracTickets for help on using tickets.