WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 4 months ago

#43354 closed defect (bug) (duplicate)

emoji broken in firefox 58

Reported by: Otshelnik-Fm Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.4
Component: Emoji Keywords:
Focuses: Cc:
PR Number:

Description (last modified by pento)

Bug in WordPress 4.9.3, 4.9.4 in firefox 58.0.2 (64-bit). In chrome, edge - works.

On 4.7.9 - works

screens https://ru.wordpress.org/support/topic/%d0%bf%d0%be%d0%bb%d0%be%d0%bc%d0%b0%d0%bb%d0%b8%d1%81%d1%8c-emoji/

Change 5101 lines in formatting.php 4.9.3:

case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039])

on:

case"emoji":return b=d([55358,56692,8205,9792,65039],[55358,56692,8203,9792,65039])

and all works

Change History (1)

#1 @pento
4 months ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Going to close this as a duplicate of #46404, there's ongoing work to improve the detection in all browsers and OSes, including Firefox.

Note: See TracTickets for help on using tickets.