WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#43377 closed enhancement (duplicate)

Media library folders?

Reported by: dingo_d Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.4
Component: Media Keywords:
Focuses: Cc:

Description

While there are a lot of plugins out there that add extra media library functionality, now that we basically have folder tree in the Editor (for themes and plugins), how come we don't have the same functionality in the Media library? Just show the uploads folder and subfolders on the right side in a sidebar, and show the corresponding items in the content to the left.

Is it possible to add, or are there some extra hard things that are preventing this?

One thing that happens when you have a lot of images and files, is that the media library can become really slow - especially when you show a lot of files in it. This could remedy it by showing only items from the specific folder user selected.

I see one possible issue here, and that is how would we prevent showing all the cropped images that are usually stored in the uploads folders?

We could even add the ability to create folders using the filesystem API.

Thoughts?

Change History (3)

#1 @dingo_bastard
4 years ago

  • Keywords 2nd-opinion dev-feedback needs-testing needs-design ui-feedback ux-feedback added

#2 @ocean90
4 years ago

  • Focuses ui accessibility performance removed
  • Keywords 2nd-opinion dev-feedback needs-testing needs-design ui-feedback ux-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23594 and #39644.

#3 @dd32
3 years ago

  • Reporter changed from dingo_bastard to dingo_d
Note: See TracTickets for help on using tickets.