Make WordPress Core

Opened 6 years ago

Closed 23 months ago

#43424 closed enhancement (duplicate)

Use access modifiers in POMO library

Reported by: sergeybiryukov's profile SergeyBiryukov Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords:
Focuses: Cc:

Description

Background: #22234, #42803.

Most of class methods and properties in WordPress core have proper access modifiers now.

The POMO library was left out of these changes at the time, see comment:16:ticket:22234.

Newer commits do have the proper modifiers though: [38961], [39591], [41722], so I guess the older code should be updated as well for consistency. It's a standalone library, but not really an external one and can be modified as needed.

Change History (2)

This ticket was mentioned in Slack in #core-php by sergey. View the logs.


6 years ago

#2 @swissspidy
23 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #54177.

I think this was made obsolete by [51919]

Note: See TracTickets for help on using tickets.