WordPress.org

Make WordPress Core

Opened 3 years ago

Last modified 3 months ago

#43460 new defect (bug)

Published Post reverts to draft

Reported by: richards1052 Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.9.4
Component: Posts, Post Types Keywords: reporter-feedback close
Focuses: Cc:

Description

When I publish a post which has previously been saved in draft format, it will sometimes revert back to draft without my having done anything to change the status myself.

I believe this only happens with posts which originally were saved in draft format. I don't think it happens with posts which are published directly without being saved in draft format.

Also, I worked on the post both in my PC browser and using the WP Android smartphone app. I don't know if there may be a conflict between them which could cause this.

When I review the revisions I see that the published post reverts back to the last time it was in draft mode. I can rectify this by reverting to the published version, which is how I fix it.

I have researched this online and have found other users affected by the same issue on both self-hosted & WP-hosted sites going back to 2012. The technical staff advice offered in the WP.com forums doesn't offer an explanation for the problem.

I have searched for this bug and haven't found it mentioned, though it's possible the search feature didn't pick up a previous report.

Attachments (1)

Here are all logs with timestamps.docx (12.4 KB) - added by richards1052 3 years ago.
log of post revisions

Download all attachments as: .zip

Change History (4)

@richards1052
3 years ago

log of post revisions

#1 in reply to: ↑ description @SergeyBiryukov
3 years ago

  • Component changed from Post Formats to Posts, Post Types
  • Keywords reporter-feedback added

Hi @richards1052, welcome to WordPress Trac! Thanks for the report.

I have researched this online and have found other users affected by the same issue on both self-hosted & WP-hosted sites going back to 2012.

Could you link to those discussions?

#2 @hellofromTonya
4 months ago

  • Keywords close added

Hello @richards1052,

Hmm, I'm unable to reproduce this problem.

Are you still having this problem on your site?

  • Yes => What happens when deactivating all plugins and switching to a default theme? Does the problem go away?
  • No => Do you remember what the root cause was?

I'm not finding other reports in Trac of this specific problem.

I'm marking this ticket as a close worksforme candidate. Please don't be alarmed. We mark tickets for close consideration when we are unable to reproduce and suspect the problem is not due to WordPress core. However, when more information is given, we reevaluate.

This ticket was mentioned in Slack in #meta by joyously. View the logs.


3 months ago

Note: See TracTickets for help on using tickets.