WordPress.org

Make WordPress Core

#43612 closed defect (bug) (fixed)

404 error when downloading plugin from WordPress.org repository

Reported by: Arthur Gareginyan Owned by:
Milestone: WordPress.org Priority: normal
Severity: normal Version:
Component: WordPress.org site Keywords:
Focuses: Cc:
PR Number:

Description

I received emails from few users who can not download my plugin that hosted in the repository at WordPress.org. When I try to download the plugin using the "Download" button, it always fails with the following error message:

404 Not Found
The requested URL /social-media-buttons-toolbar/social-media-buttons-toolbar.4.30.zip was not found on this server.

This happened after updating the plugin to the new version (v4.30). The previous version (v4.29) of the plugin is downloading without any errors. Other my plugins that hosted in the repository at WordPress.org are downloads without errors.

I thought this would be a temporary problem, but the problem is still there after ten hours. I checked the Trac and SVN, and I see that the plugin is there. So the problem only occurs with the plugin's ZIP file.

The plugin here:
https://wordpress.org/plugins/social-media-buttons-toolbar/

Link to the ZIP file of the current version of the plugin (works fine):
https://downloads.wordpress.org/plugin/social-media-buttons-toolbar.4.29.zip

Link to the ZIP file of the new version of the plugin (404 error):
https://downloads.wordpress.org/plugin/social-media-buttons-toolbar.4.30.zip

I hope this is the right way to request help on this issue, and thanks for your help!

Change History (1)

#1 @Otto42
19 months ago

  • Component changed from Plugins to WordPress.org site
  • Milestone changed from Awaiting Review to WordPress.org
  • Resolution set to fixed
  • Status changed from new to closed

This was fixed this morning. Large plugins would have a problem building zip files for download.

Make any change to your plugin and that will trigger a rebuild.

Note: See TracTickets for help on using tickets.