WordPress.org

Make WordPress Core

Opened 21 months ago

Closed 5 months ago

#43684 closed defect (bug) (worksforme)

append blank line in front of a table when switching from text to visual editor

Reported by: max345 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.4
Component: TinyMCE Keywords:
Focuses: Cc:
PR Number:

Description

" " is appened in front of a table when switching from text editor to visual editor if the cursor is at the begining of the textarea or the textarea doesn't have focus.

To reproduce this bug, create a new post, choose tab "text editor", add the following:

<table>
<tbody>
<tr>
<td>hello</td>
</tr>
</tbody>
</table>

Then save draft and change to "visual editor".

Now the table has a blank line above and if you return to text editor you see this:

&nbsp;
<table>
<tbody>
<tr>
<td>hello</td>
</tr>
</tbody>
</table>

This bug happens in 4.9.x, not in 4.8.5.

Change History (1)

#1 @azaozz
5 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce this in WP 5.2. Also this is now superseded by the block editor. The Table block works well there.

Closing as worksforme. Feel free to reopen if this still happens and needs fixing in the classic editor.

Note: See TracTickets for help on using tickets.