Make WordPress Core

Opened 6 years ago

Closed 19 months ago

#43720 closed defect (bug) (invalid)

Image Resize Bug (Media settings)

Reported by: felln's profile Felln Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords: reporter-feedback
Focuses: Cc:

Description

I found an image resize bug, and can reproduce it with different wordpress instances.
Steps:

  1. Go to Dashboard. Settings -> Media
  2. Set Medium Size Max Width and Max Height to 600
  3. Go to media and upload a picture with size 512x1024
  4. Make a post and insert the picture in the sample post via insert media button.
  5. Edit the image size in the post to Medium Size (300x600).

At step 4 when i want to insert the picture: I have a non seen image in my library (as thumbnail. It will only show grey). When i insert it in full size i will see it in the post itself. After setting it to Medium size the picture is gone...

When i resize the image with 1 pixel only (like 511x1ß24) all is good. When i make diretcly a resize to 300x600 and upload it i have the same bug. It have something to do with the media settings. When i use other px settings at the media settings (step 2) the pictures work.
I can reproduce it with 2 different WordPress instances

Change History (5)

#1 @Felln
6 years ago

  • Summary changed from Image Size Bug to Image Resize Bug (Media settings)

#2 @pento
5 years ago

  • Version trunk deleted

#3 @joemcgill
5 years ago

  • Keywords reporter-feedback added

Hi @Felln,

I'm unable to reproduce this bug using the steps you've outlined in WordPress version 5.2-beta3. It sounds to me like there is a problem with the way the server is generating intermediate image size files on your system. Can you provide additional details about your system, specifically what version of GD or ImageMagick is being used on these installs?

This ticket was mentioned in Slack in #core-media by antpb. View the logs.


19 months ago

#5 @antpb
19 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

It's been 4 years with no response on this ticket so I'm going to close this to keep our open ticket backlog true.

Feel free to reopen if this is still an issue! thanks!

Note: See TracTickets for help on using tickets.