Make WordPress Core

Opened 4 years ago

Closed 2 years ago

Last modified 2 years ago

#43773 closed defect (bug) (worksforme)

TinyMCE: some keyboard shortcuts are not displayed in the tooltips

Reported by: afercia Owned by:
Milestone: Priority: low
Severity: normal Version: 4.7
Component: Editor Keywords: has-patch has-screenshots
Focuses: Cc:


In [38897] some TinyMCE keyboard shortcuts were made more discoverable by adding them to the buttons tooltips. However, some of them aren't displayed correctly.

When the user language is set to English:

  • Bulleted list: no shortcut displayed
  • Numbered list: OK
  • Insert/edit link: no shortcut displayed

When the user language is set to any other language:

  • none of them works

Seems to me the Insert/edit link case is simpler, while the lists are a bit more tricky because they are actually a TinyMCE plugin.

Attachments (1)

43773.diff (2.4 KB) - added by afercia 4 years ago.

Download all attachments as: .zip

Change History (15)

4 years ago

#1 @afercia
4 years ago

  • Keywords has-patch has-screenshots added; needs-patch removed

43773.diff works but is, in a way, a hack. To my understanding, ideally the tooltip property should be added in the lists buttons object in the lists plugin, see src/wp-includes/js/tinymce/plugins/lists/plugin.js so a fix upstream would probably be the best option. /Cc @azaozz @iseulde

#2 @desrosj
4 years ago

  • Keywords dev-feedback added

I was able to reproduce the issue described and 43773.diff does fix the problem.

@azaozz or @iseulde, do you have any thoughts on this for 4.9.6?

This ticket was mentioned in Slack in #core by desrosj. View the logs.

4 years ago

This ticket was mentioned in Slack in #core by desrosj. View the logs.

4 years ago

#5 @desrosj
4 years ago

  • Milestone changed from 4.9.6 to 4.9.7

Waiting for a 2nd opinion. Punting.

#6 @ocean90
4 years ago

  • Milestone changed from 4.9.7 to 4.9.8

4.9.7 has been released, moving to next milestone.

This ticket was mentioned in Slack in #core by pbiron. View the logs.

4 years ago

#8 @pento
4 years ago

  • Milestone changed from 4.9.8 to Awaiting Review

4.9.8 is in RC.

This needs feedback from @iseulde or @azaozz to move forward, so I'm moving it to Awaiting Review.

#9 @afercia
4 years ago

  • Milestone changed from Awaiting Review to 4.9.9

I'm not sure "Awaiting Review" is the proper milestone. "Awaiting Review" is meant for fresh tickets that haven't been reviewed yet. Tickets marked as such go in the awaiting review report. This ticket has already been initially reviewed, marking it again with "Awaiting Review" will pollute the related report and increase the work load for the component maintainers and bug gardeners. In such cases, I'd say a more proper milestone is the next milestone (if any) or "Future Release".


#10 @pento
3 years ago

  • Milestone changed from 4.9.9 to Future Release

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.

3 years ago

#14 @desrosj
2 years ago

  • Keywords dev-feedback removed
  • Priority changed from normal to low
  • Resolution set to worksforme
  • Status changed from new to closed

I did some testing on this and it seem that this was solved in another ticket as I can no longer reproduce. To test, I followed the steps above using both English and German and the Classic Editor plugin, but all shortcuts correctly displayed in the tooltips.

If anyone is able to reproduce this, feel free to reopen and provide more details to reproduce. I am marking this as low priority because it affects only the Classic Editor. I did some searching but was unable to find another ticket addressing this. If someone knows where this was solved, please just drop a comment to connect the dots.

#15 @desrosj
2 years ago

One more scenario that I tested and forgot to mention: using the Classic block in the block editor with English and German. Both worked as expected.

#16 @afercia
2 years ago

Right. Fixed in [45066] / #35710.

Note: See TracTickets for help on using tickets.