WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#43775 closed defect (bug) (invalid)

Three-way conflict between WordPress Revisions, and UpdraftPlus plugin, and Galleries by Angie Makes plugin; Sharefaith website — at Version 1

Reported by: larzarino Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description (last modified by Clorith)

Sat, 14 April 2018 about 2:30 PM Pacific Time USA

SUBJ: Three-way conflict between WordPress Revisions, and UpdraftPlus plugin, and Galleries by Angie Makes plugin; Sharefaith website

Background: I am relatively new to WordPress. This occurred on my Sharefaith WordPress website.

I set up a workflow environment which includes backing up (UpdraftPlus). Yesterday, as a test, I made a change on a page and published it which generated a new "revision" of that page — but a problem cropped up: "Revisions" did not show up. Let's put it this way: I had a shit-fit (I went ballistic). Where was "Revisions"? My software-engineer-husband got involved, and determined that when he DEactivated UpdraftPlus, "Revisions" showed up. When he (RE)activated UpdraftPlus, Revisions did not show up. AGAIN, when he DEactivated UpdraftPlus, Revisions showed up. One or the other of UpdraftPlus and Revisions showed up but never at the same time.

It appears I can have either Revisions or UpdraftPlus, but not both at the same time. But… there was a third plugin running/active: "Galleries by Angie Makes" — a plugin I had not spotted earlier.

I had an aha: Maybe this third plugin has something to do with the problem.

I said, "I have to deactivate THAT plugin too." So I DEactivated "Galleries by Angie Makes."

Lo and behold, I did a couple tests, and now Revisions works fine WHILE UpdraftPlus is active. Yahoo!!

Therefore, my hypothesis is: There is a three-way conflict between Wordpress Revisions, and UpdraftPlus plugin, and Galleries by Angie Makes plugin.

I have done my duty now by telling all three parties: Wordpress.org; UpdraftPlus; Galleries by Angie Makes, of the bug. You all figure the rest out.

I don't need a reply.

Thank you.

Laura

Change History (1)

#1 @Clorith
4 years ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hiya, and welcome to WordPress' bugtracker.

As you've mentioned, this is a plugin conflict, and the core WordPress software behaves as expected when the plugins are disabled. As such I'm going to close this ticket as invalid from our end, it should be fixed by the plugins causing the conflict at this time.

You did mention having informed them of the issue, so I expect they'll get to it when they have a chance. Thank you for taking the time to track down the cause though, as I am certain that may help others in the same situation as well!

Note: See TracTickets for help on using tickets.