WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 weeks ago

#43777 closed enhancement (duplicate)

Refactor Customizer expandable section JS for ease of reuse for core, themes, plugins

Reported by: joyously Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Customize Keywords:
Focuses: javascript Cc:

Description

In the Customizer, the widgets section and the menu section have expandable portions. This code seems to be duplicated, and yet not reusable for themes/plugins to easily create expandable portions.

This should be part of the object inheritance for the Core Customizer objects.

Same question asked at WPSE in early 2016: https://wordpress.stackexchange.com/questions/214189/

Change History (2)

This ticket was mentioned in Slack in #themereview by joyously. View the logs.


3 years ago

#2 @celloexpressions
3 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #36733, and the decision there is to not address this in core for now, since the widgets version is now using the block editor inserter.

It would be great to see someone create a reusable section class for this, that could be reused in various plugins as needed.

Note: See TracTickets for help on using tickets.