WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#43786 closed defect (bug) (invalid)

Post comment by guest gets auto approved

Reported by: subrataemfluence Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.5
Component: Comments Keywords:
Focuses: Cc:

Description

When I post a comment as a guest against a Post, it awaits moderation. If the comment is approved and I post another comment as guest with the same email address which I used in the last comment, the comment gets approved automatically.

I think this should be treated a major bug since the moderation is meant for comments, not the email address.

Even a guest comment was approved with abc@bcd.com, WordPress should not by default approve the next comment automatically only because there is another comment associated with the same email address and was approved before!

The moderation should take only the comment body into consideration.

Change History (3)

#1 follow-up: @swissspidy
2 years ago

  • Keywords close added

That's not a bug, but an option you can set in your discussion settings.

Under Settings -> Discussion -> "Before a comment appears" uncheck the "Comment author must have a previously approved comment" setting and make sure "Comment must be manually approved" is checked.

#2 in reply to: ↑ 1 @subrataemfluence
2 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Replying to swissspidy:

That's not a bug, but an option you can set in your discussion settings.

Under Settings -> Discussion -> "Before a comment appears" uncheck the "Comment author must have a previously approved comment" setting and make sure "Comment must be manually approved" is checked.

Thank you for letting me know!

#3 @swissspidy
2 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.