WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 21 months ago

Last modified 21 months ago

#43840 closed defect (bug) (duplicate)

CSS variables are flagged as errors in Theme Editor

Reported by: kandb Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

When using theme-editor.php to edit CSS, Our code shows "There is x error which must be fixed before you can update this file." when using variables in :root

eg, the following code has an error with 'Expected RBRACE...'

:root {

--redpink: #f05562;

}

Change History (2)

#1 @joyously
21 months ago

  • Component changed from Themes to Editor
  • Resolution set to duplicate
  • Severity changed from major to normal
  • Status changed from new to closed
  • Summary changed from Allow configuration variables as :root properties to CSS variables are flagged as errors in Theme Editor

It's not that :root is considered an error.
The problem is that it doesn't know about CSS Custom Properties. That means that although this ticket came before #44471, it doesn't have the comments that that one does, but it's the same thing, so I'm going to close this as duplicate.

#2 @desrosj
21 months ago

  • Milestone Awaiting Review deleted
  • Version 4.9.5 deleted
Note: See TracTickets for help on using tickets.