WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 6 months ago

#43855 closed defect (bug) (duplicate)

Comments with date in the future must not showing

Reported by: smartgest Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords:
Focuses: Cc:
PR Number:

Description

If I change date of a comments to "now +1 day", the comments is show and display the date in the future. This is not ok. The comments must check the date and display if the date of comments is <= with now.

Change History (1)

#1 @earnjam
6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @smartgest and welcome to WordPress Trac!

This is a duplicate of #4543 and I don't think the mindset has changed from that. Posts with a date in the future are not shown because of the post status of future, not because of the date specifically. Comment dates can only be edited after being submitted, so there isn't really any scheduling that could occur.

I'm going to close this as a duplicate.

Note: See TracTickets for help on using tickets.