WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 8 months ago

#43859 closed defect (bug) (worksforme)

UI adjustments for select month dropdown. Make the select month input height and font size same as other inputs.

Reported by: jainnidhi Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: reporter-feedback
Focuses: ui, administration Cc:

Description

The select month input height and font size on the quick-edit forms are not same as the other inputs for posts, like they are in the post- and comment edit screens.

It looks like this can fixed by e.g. adjusting the margins/height/font size. The quick-edit forms are not using same style like other input (date, year, time) fields.

Attachments (5)

select-height-not-equal.png (54.4 KB) - added by jainnidhi 3 years ago.
Select month input height and font size not equal as other inputs(date, year, time).
select-height-equal.png (26.1 KB) - added by jainnidhi 3 years ago.
Select month input height and font size equal as other inputs(date, year, time) in post and comment edit screens.
43859.diff (425 bytes) - added by jainnidhi 3 years ago.
I've added a patch 43859.diff for this fix.
select-input-height.png (48.6 KB) - added by jainnidhi 9 months ago.
43859.1.2.diff (717 bytes) - added by jainnidhi 9 months ago.
I've fixed this issue in this patch.

Download all attachments as: .zip

Change History (12)

@jainnidhi
3 years ago

Select month input height and font size not equal as other inputs(date, year, time).

@jainnidhi
3 years ago

Select month input height and font size equal as other inputs(date, year, time) in post and comment edit screens.

@jainnidhi
3 years ago

I've added a patch 43859.diff for this fix.

#1 @jainnidhi
3 years ago

  • Keywords has-patch has-screenshots added

#2 @valentinbora
9 months ago

  • Keywords reporter-feedback added

Thank you @jainnidhi for the ticket and sorry for the long delay for us to respond.

I've taken another look at both the current trunk at [47293], as well as 5.4 Beta 1 and it seems the issue has been resolved in the meantime.

It would be great if you could take another look and confirm whether this is still an issue or if we could consider closing the ticket.

#3 @jainnidhi
9 months ago

Hey @valentinbora

I've checked this and it's fixed now.

#4 @valentinbora
9 months ago

  • Focuses administration added
  • Keywords has-patch has-screenshots reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to fixed
  • Status changed from new to closed
  • Type changed from enhancement to defect (bug)
  • Version 4.9.5 deleted

Thank you so much @jainnidhi for getting back to us so quickly. Highly appreciated.

I'll go ahead and close this ticket as fixed, but it can always be reopened if needed.

#5 @jainnidhi
9 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hey @valentinbora
This issue has been fixed in Post Quick Edit but still appearing in Post Document settings. So I am going to reopen this ticket.

See attached.

@jainnidhi
9 months ago

I've fixed this issue in this patch.

#6 @valentinbora
9 months ago

  • Keywords reporter-feedback added

Hey @jainnidhi.

Could you share more details about the environment this is happening in (OS, Browser, WordPress version)?

I've tested this on a Mac, with WordPress 5.4-beta1 and trunk, on both Firefox and Chrome and I can't reproduce the issue.

#7 @jainnidhi
8 months ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

I am going to close this because It has been fixed in WP 5.4 .

Note: See TracTickets for help on using tickets.