WordPress.org

Make WordPress Core

Opened 7 weeks ago

Closed 7 weeks ago

#43906 closed enhancement (duplicate)

A child theme should inherit its parent theme's custom CSS when switching themes

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Customize Keywords: needs-patch
Focuses: Cc:

Description

Situation:

I install a theme and begin customising it with some custom CSS. At some point I realise I need to create a child theme, so I do so. Upon switching to the child theme, all my custom CSS disappears. Not fun.

When switching to a child theme, its parent theme's custom CSS should be inherited if the child theme doesn't have any custom CSS stored already.

Change History (2)

#1 @westonruter
7 weeks ago

Is this not the same problem as theme mods in general? When switching between a parent and child theme and between sibling child themes. So maybe this is a duplicate of #27177?

#2 @johnbillion
7 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #27177.

Note: See TracTickets for help on using tickets.