WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 19 months ago

Last modified 19 months ago

#43909 closed defect (bug) (fixed)

Improve styling on personal data tables

Reported by: allendav Owned by: azaozz
Milestone: 4.9.6 Priority: normal
Severity: normal Version: 5.1
Component: Privacy Keywords: gdpr has-patch needs-testing commit
Focuses: Cc:
PR Number:

Description

  • When personal data export via email fails, the Retry button label baseline should be the same as the Email Failed! text
  • The request-results row added to the table below a request should match the styles (e.g. background light blue for confirmed) for the request it is associated with.

cc @melchoyce

Attachments (6)

43909.diff (379 bytes) - added by allendav 20 months ago.
Fixes email retry baseline
43909.2.diff (1.9 KB) - added by allendav 20 months ago.
Fixes request result row styles to blend into request row (box shadow, background, left border) for confirmed or failed requests
wut.png (159.5 KB) - added by allendav 20 months ago.
Improved styles
wut-wut.png (131.6 KB) - added by melchoyce 19 months ago.
43909.3.diff (2.0 KB) - added by allendav 19 months ago.
Updated to tighten top and bottom margins on notices
wut-wut-wut.png (98.3 KB) - added by allendav 19 months ago.
Updated to tighten top and bottom margins on notices

Download all attachments as: .zip

Change History (24)

@allendav
20 months ago

Fixes email retry baseline

@allendav
20 months ago

Fixes request result row styles to blend into request row (box shadow, background, left border) for confirmed or failed requests

@allendav
20 months ago

Improved styles

#1 @allendav
20 months ago

To test:

Easiest way is to add this to the top of wp_privacy_process_personal_data_export_page in wp-admin/includes/file.php near line 2261

wp_send_json_error( __( 'Wut' ) );

And then attempt to send some emails for some export requests. Be sure to try a confirmed one since it has the blue background and border.

#2 @allendav
20 months ago

  • Keywords has-patch needs-testing added; needs-patch removed

This ticket was mentioned in Slack in #gdpr-compliance by allendav. View the logs.


20 months ago

#4 follow-up: @melchoyce
19 months ago

It looks like you're not reusing existing notice classes — is there a reason you're duplicating the CSS in new classes instead of using existing classes?

#5 in reply to: ↑ 4 @allendav
19 months ago

Replying to melchoyce:

It looks like you're not reusing existing notice classes — is there a reason you're duplicating the CSS in new classes instead of using existing classes?

Hi @melchoyce ! We looked at the plugins page to mimic how it is constructed and styled and we do use .notice, .inline, .notice-alt, .notice-error from common.css on this page in the same way as the plugins page.

As for the box-shadow removal and background color copying - the styles on the plugins page are plugins table specific (in list-tables.css with things like .plugins .update td) and that's why I duplicated a tiny bit of CSS here for the requests tables.

Is that what you mean?

This ticket was mentioned in Slack in #gdpr-compliance by allendav. View the logs.


19 months ago

#7 @melchoyce
19 months ago

Ah, sorry — I noticed the margin around the notice was different from the plugin page, and then didn't see the <div class="notice inline notice-alt ' + classes + '"> in your latest patch. I think the margin above and below the notice should be narrower. I'm attaching an example based on the spacing I'm seeing in plugins.

@melchoyce
19 months ago

#8 @postphotos
19 months ago

This looks good, @melchoyce and @allendav! Thank you for your work here.

#9 @desrosj
19 months ago

  • Keywords needs-refresh added

#10 @desrosj
19 months ago

  • Milestone changed from Awaiting Review to 4.9.6

This is an easy win. Let's get this in right after beta.

This ticket was mentioned in Slack in #core by desrosj. View the logs.


19 months ago

@allendav
19 months ago

Updated to tighten top and bottom margins on notices

@allendav
19 months ago

Updated to tighten top and bottom margins on notices

#12 @allendav
19 months ago

  • Keywords needs-refresh removed

@melchoyce - margins updated - thank you for the feedback!

This ticket was mentioned in Slack in #gdpr-compliance by allendav. View the logs.


19 months ago

#14 @melchoyce
19 months ago

  • Keywords commit added

Screenshot looks good, let's get this in.

This ticket was mentioned in Slack in #core by desrosj. View the logs.


19 months ago

#16 @azaozz
19 months ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 43216:

Privacy: fix styling on personal data tables.

Props melchoyce, allendav.
Fixes #43909.

#17 @azaozz
19 months ago

In 43217:

Privacy: fix styling on personal data tables.

Props melchoyce, allendav.
Merges [43216] to the 4.9 branch.
Fixes #43909.

#18 @desrosj
19 months ago

  • Component changed from General to Privacy

Moving to the new Privacy component.

Note: See TracTickets for help on using tickets.