Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#43959 closed defect (bug) (duplicate)

Twenty Seventeen: Responsive width bug

Reported by: woodchuckcanuck's profile woodchuckcanuck Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

Hi,

Hope this is the right area to report. I recently installed WP on site FreeWoodworkingPlan.com We like the Twenty Seventeen theme as a layout. The width responsive ness is fine in desktop. But it is not on mobile device. In particular, the header title. I shouldn't have to abbreviate my title, I figured the code would adjust the text to fit the screen. Can you offer any assistance? Thanks.

Jim Barry

Attachments (3)

temp-FWPtheme-android.png (927.1 KB) - added by woodchuckcanuck 6 years ago.
theme viewed on android
43959.diff (857 bytes) - added by ianbelanger 6 years ago.
addition of hypens: auto; to .site-title
43959.1.diff (471 bytes) - added by ianbelanger 6 years ago.
Removes CSS from previous ticket I was working on

Download all attachments as: .zip

Change History (10)

@woodchuckcanuck
6 years ago

theme viewed on android

@ianbelanger
6 years ago

addition of hypens: auto; to .site-title

#1 @woodchuckcanuck
6 years ago

While I've had 20 yrs of html and php basic coding experience, WP is new to me. Where do I find wp-admin/css/media.css?

I've edited the other file.

Thanks,
Jim

@ianbelanger
6 years ago

Removes CSS from previous ticket I was working on

#2 @ianbelanger
6 years ago

Hi @woodchuckcanuck, If this patch gets accepted into core, this fix will be in the next release of the theme. If you are looking for a solution now, I would recommend using the css editor in Apperance -> Customize. Another option is it looks like there are no spaces in your title. If there were spaces it would naturally break to new lines.

#3 @xkon
6 years ago

Are we sure that any site title should be hyphened at all? What I mean is that we're talking about the sites title here not a post and that might be connected straight to branding most of the times.

By hyphening it by default it breaks the whole branding idea.

I don't think this is a theme's matter at all imho, the title could be easily made smaller in responsive design if any user didn't had issues with that, but not by default.

#4 @woodchuckcanuck
6 years ago

@ianbelanger You are correct in that there is no spaces (breaks). I've always typed it like that for the title, it never dawned on me to type it normally. Duh. I'll give that a try.
@xkon Your raise a good point regarding branding. One of our other trademarks has two words, just as many letters, and has to run together for branding and trademark purposes. Smaller text would work for the title, but again, I don't know where to start, otherwise I would of tweaked it already. When I first installed WP and minor tweaked a page, I ended up having to do a re-install. So I'm a bit leary on making changes.

Thanks for all your comments.

#5 @SergeyBiryukov
6 years ago

  • Component changed from General to Bundled Theme
  • Version 1.5 deleted

#6 @SergeyBiryukov
6 years ago

  • Summary changed from Twenty Seventeen responsive width bug to Twenty Seventeen: Responsive width bug

#7 @ianbelanger
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #36346.

Note: See TracTickets for help on using tickets.