WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#43972 closed defect (bug) (duplicate)

Requests never become completed - GDPR

Reported by: garrett-eclipse Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Privacy Keywords: gdpr
Focuses: administration Cc:

Description

Hello,

While playing with GDPR I noticed that the process flow never completes and always stays in the Confirmed state. This seems to be the case with both the removal and the export request processes.

Upon emailing or removing of the data the request should be updated to 'Completed' and appear in the 'Completed' view. It should also indicate this in the Sttatus with the time as to when it was completed.

I'm not sure if the Completed state has anything for 'Next Steps' but for the export request maybe the Next Steps are 'Email Data Again' while for the removal request I guess there would be no next steps or maybe should have re-remove data?

Currently there's no indication that the data export was sent or the data was removed so other admin users logging into the interface would see the request in confirmed state and trigger the next steps which could be frustrating for the user receiving multiple emails.

Thank you

Attachments (1)

Screen Shot 2018-05-04 at 1.29.35 PM.png (42.4 KB) - added by garrett-eclipse 3 years ago.
Request table showing completed request as confirmed

Download all attachments as: .zip

Change History (4)

@garrett-eclipse
3 years ago

Request table showing completed request as confirmed

#1 @xkon
3 years ago

  • Keywords gdpr added
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hey @garrett-eclipse thanks for the report!

This is a duplicate of #43913 ( export ) and #43922 ( removal ) and there is a patch there for both already fixing this it was just not committed yet.

Closing this to avoid extra efforts at the moment.

#2 @garrett-eclipse
3 years ago

Thanks @xkon I've subscribed there, appreciate the references.

#3 @desrosj
3 years ago

  • Component changed from General to Privacy

Moving to the new Privacy component.

Note: See TracTickets for help on using tickets.