WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 16 months ago

#43996 closed defect (bug) (wontfix)

Privacy admin pointer misaligned when 3rd party menu items exist

Reported by: iandunn Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Privacy Keywords: gdpr
Focuses: ui Cc:

Description

An admin pointer was added in r43158 for the new Privacy and Personal Data tools. On a fresh install, the pointer is correctly aligned between the Tools and Settings menus. If plugins add additional menus, though, it can become misaligned.

Attachments (1)

screen-shot-2018-05-05-at-7-15-24-am.jpg (153.4 KB) - added by iandunn 17 months ago.
Screenshot of misalignment due to extra menus

Download all attachments as: .zip

Change History (9)

@iandunn
17 months ago

Screenshot of misalignment due to extra menus

#1 @desrosj
17 months ago

  • Keywords close added; needs-patch removed

#43961 is closely related. The fix suggested in https://core.trac.wordpress.org/ticket/43961#comment:6 will also fix this issue. Not going to close just yet, but a patch for this will most likely not be needed so marking close.

This ticket was mentioned in Slack in #gdpr-compliance by allendav. View the logs.


17 months ago

#3 @iandunn
17 months ago

  • Keywords close removed

I'm still able to reproduce the problem after r43210. I needed to add about 10 menus, and resize the viewport to the point where the menu would scroll a bit (e.g., 1366x768). Another factor is where you're scrolled when you refresh the page (top or bottom).

If there isn't enough time to fix this for 4.9.6, though, then it's probably a moot point, since I'm guessing the pointer will be removed in 4.9.7 anyway.

This ticket was mentioned in Slack in #core by iandunn. View the logs.


17 months ago

#5 @desrosj
17 months ago

  • Keywords close added

This will probably be a rare occurrence, and I agree with @iandunn that this will most likely be a short lived thing. Marking as close, and if no one is able to propose a solution before the RC this afternoon, we can close as a wontfix.

#6 @desrosj
17 months ago

  • Keywords close removed
  • Milestone 4.9.6 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

#7 @iandunn
17 months ago

#44045 is a new report of this with a patch.

#8 @desrosj
16 months ago

  • Component changed from Administration to Privacy

Moving to the new Privacy component.

Note: See TracTickets for help on using tickets.