WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#4401 closed defect (bug) (worksforme)

Hebrew characters being changed to question marks

Reported by: illuminea Owned by:
Milestone: Priority: high
Severity: normal Version: 2.2
Component: I18N Keywords: language, hebrew reporter-feedback
Focuses: Cc:

Description

I updgraded a few sites to WordPress 2.2. At that point, any time I tried to enter a post or page in Hebrew, upon pressing Save or Publish the Hebrew characters became question marks (?). I tested this out on a few different servers, with the same results. I tested it with different themes, and turning all plugins off. Same results. I tested it on different computers - same results. I tried changing the encoding, changing the meta information in the header - same results.

I then went to two different sites that I manage that run on 2.0.5 and 2.1.2 respectively. On those sites, the Hebrew came out fine.

It is possible that this problem may extend to other languages with non-alphabetic letters.

Change History (4)

comment:1 foolswisdom7 years ago

Can you include some examples.

comment:2 darkdragon6 years ago

  • Component changed from General to i18n

comment:3 thee176 years ago

  • Keywords reporter-feedback added
  • Milestone changed from 2.4 to 2.5

comment:4 pishmishy6 years ago

  • Milestone 2.6 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

We've received no feedback and the interface has changed significantly since you first reported the problem. As you're not the only use of WordPress in Hebrew (see http://wph.co.il/) I'll presume that the problem did exist but is now fixed.

I'm going to close this ticket but if you do get the chance we'd appreciate you testing the latest version of WordPress and let us know your findings here. If you do have problems, please give us instructions on how to reproduce them.

Note: See TracTickets for help on using tickets.