WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 6 months ago

Last modified 6 months ago

#44011 closed enhancement (duplicate)

link to gmpg.org for XFN should now be https everywhere in core and core themes

Reported by: WebDragon Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.5
Component: General Keywords: has-patch
Focuses: Cc:

Description

In order to push forward with https-everywhere, this will need correction.

https://gmpg.org/xfn/11 is now fully functional as https, and there is no reason to avoid working the change into the wordpress core, as well as in core themes.

my current blog has mostly single-occurance in header.php, but one stood out with over 36 occurrances within:

$ ack -cl 'http://gmpg.org'

wp-content/themes/twentyeleven/header.php:1
wp-content/themes/twentyten/header.php:1
wp-content/themes/twentytwelve/header.php:1
wp-content/themes/tempera/header.php:1
wp-content/themes/twentyten-madhouse/header.php:1
wp-content/themes/twentyfourteen/header.php:1
wp-content/themes/twentythirteen/header.php:1
wp-content/themes/twentythirteen-madhouse/header.php:1
wp-content/plugins/siteorigin-panels/tpl/live-editor-preview.php:1
wp-admin/includes/meta-boxes.php:36
wp-admin/edit-link-form.php:1
wp-includes/theme-compat/header.php:1

This will help avoid mixed-content warnings from some reporting algorithms and services on the web, and since it now works, there is no reason not to do so.

Attachments (1)

44011.diff (19.0 KB) - added by audrasjb 3 years ago.
Replace http with https in xfn links

Download all attachments as: .zip

Change History (4)

@audrasjb
3 years ago

Replace http with https in xfn links

#1 @audrasjb
3 years ago

  • Keywords has-patch added; needs-patch removed

Hi and thank you for this ticket,

I guess this is a nice idea.
In 44011.diff: Replace http with https in xfn links

Note
These files are not WordPress Core files and depends on plugins/themes authors:

  • wp-content/themes/tempera/header.php
  • wp-content/themes/twentyten-madhouse/header.php
  • wp-content/themes/twentythirteen-madhouse/header.php
  • wp-content/plugins/siteorigin-panels/tpl/live-editor-preview.php

#2 @sabernhardt
6 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #48002.

Thanks for the ticket. These links were updated to HTTPS for WordPress 5.5, in changesets [48290] and [48292].

Last edited 6 months ago by sabernhardt (previous) (diff)

#3 @SergeyBiryukov
6 months ago

  • Component changed from Security to General
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.