WordPress.org

Make WordPress Core

Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#44014 closed enhancement (duplicate)

Use wp_delete_file() instead of unlink() when generating a privacy data export file

Reported by: desrosj Owned by: iandunn
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Privacy Keywords: needs-patch gdpr
Focuses: Cc:
PR Number:

Description

In #43905, the suggestion was made to use wp_delete_file() instead of unlink() when preparing a privacy data export file. This is a good suggestion, but it was made too late in the 4.9.6 process.

Creating this ticket to keep track of this suggestion for 4.9.7.

Attachments (1)

44014.diff (398 bytes) - added by desrosj 21 months ago.

Download all attachments as: .zip

Change History (6)

@desrosj
21 months ago

#1 @iandunn
21 months ago

  • Keywords needs-patch added; has-patch removed
  • Owner set to iandunn
  • Status changed from new to accepted
  • Type changed from defect (bug) to enhancement
  • Version set to trunk

Thanks for creating this to help keep track :)

IIRC, there are a few other instances of unlink() in the 4.9.6 commits. @macbookandrew found another in https://core.trac.wordpress.org/attachment/ticket/43546/43546.patch. I think it'd be good to find them all and update them all at once.

#2 @iandunn
21 months ago

  • Keywords gdpr added

#3 @macbookandrew
21 months ago

I created a ticket and patch for the rest of the codebase: https://core.trac.wordpress.org/ticket/43990

#4 @iandunn
21 months ago

  • Milestone 4.9.7 deleted
  • Resolution set to duplicate
  • Status changed from accepted to closed

Duplicate of #43990.

Ah, nice. Thanks!

#5 @desrosj
21 months ago

  • Component changed from General to Privacy

Moving to the new Privacy component.

Note: See TracTickets for help on using tickets.